SMSSP3_OM07_MPGD.cover

Operations Manager 2007 的 Microsoft Systems Management Server 2003 Service Pack 3 管理包指南

Microsoft Corporation

发布时间：2007 年 5 月

反馈

请将您对本文档的建议和意见发送至 smsdocs@microsoft.com。请在反馈中注明管理包指南的名称。


SMSSP3_OM2007_MPGuide.copy

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the companies, organizations, products, domain names, e-mail addresses, logos, people, places, and events depicted in examples herein are fictitious. No association with any real company, organization, product, domain name, e-mail address, logo, person, place, or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2007 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows Server, and Windows Vista are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

All other trademarks are property of their respective owners.


Operations Manager 2007 的 Microsoft System Management Server 2003 管理包

欢迎使用 Operations Manager 2007 的 Microsoft® System Management Server 2003 管理包。此管理包为 SMS 2003 监视提供了新功能和经过改进的功能。

管理包资源

有关功能和资源的详细信息，请参阅以下主题。

System Management Server 2003 管理包概述

  • 管理包监视方案
  • 部署 SMS 2003 管理包
  • 执行 SMS 2003 管理包的操作任务
  • SMS 2003 管理包疑难解答
  • Microsoft System Management Server 2003 管理包参考


System Management Server 2003 管理包概述
另请参阅

本指南有助于您熟悉 SMS 2003 管理包的相关部署和技术信息。熟悉这些信息后，您就可以规划管理包部署，了解该管理包具有的功能，以及如何利用这些功能使您的 IT 部门受益。

适用于 SMS 的 System Center Operations Manager 2007 管理包增强了 SMS 2003 的监视功能，包括以下几项：

  • 监视所有 SMS 2003 服务的启动和停止，包括 Windows Management Instrumentation (WMI)、Internet Information Services (IIS)、后台智能传输服务 (BITS) 和 Microsoft SQL Server™ 等关键的依赖服务。
  • 提醒 SMS 管理员注意 SMS 关键状态消息。
  • 监视主站点服务器和管理点上的发现数据记录 (DDR) 、软件清单、硬件清单、状态消息和软件计数的积压工作。
  • 监视系统资源使用情况。
  • 监视处理速率。
  • 使用视图和报告来监视 SMS 性能计数器的性能趋势。
  • 所有警报的产品知识内容以及处理规则。
  • 检测所有 SMS 2003 计算机和计算机组。
  • 视图。
  • 显示了 SMS 2003 管理点和服务器组的性能、可用性和配置情况的报告。其中包括链接报告，增强了 Systems Center Operations Manager 2007 的性能、配置和可用性趋势报告功能。
  • 监视设备管理功能包。
  • 用于执行 SMS 管理员控制台应用程序的任务。
  • 包含所有 SMS 服务器角色和 SMS 高级客户端的运行状况的状态视图。
  • 重要的 SMS 服务器和 SMS 客户端信息的服务发现。
  • 抑制执行 SMS 站点备份时显示的“服务不可用”警报。
  • SMS 站点层次结构的拓扑图（需要安装 SMS 2003 Service Pack 3）。
  • 利用 SMS 2003 Service Pack 3 (SP3)，可通过 SMS 程序属性来配置分布式程序执行失败时显示的警报。

有关监视方案和功能的详细信息，请参阅管理包监视方案。SMS 2003 管理包不具备以下功能：

  • 监视 SMS 1.2、SMS 2.0 和 SMS 2003 SP2。
  • 监视混合的 SMS 环境。混合环境是指同时运行 SMS 1.2、SMS 2.0 和 SMS 2003 的环境。
  • 对运行 SMS 高级客户端的仅用作 SMS 客户端的计算机进行有限监视。
  • 提供全新的监视解决方案，无需任何修改即可管理任何 SMS 2003。每个 SMS 2003 产品的规则阈值都有所不同，因此客户需要自定义其规则。

本节内容

此更新中的新增功能

建议掌握的知识

支持的 SMS 配置

另请参阅

概念

管理包监视方案
部署 SMS 2003 管理包

其他资源

执行 SMS 2003 管理包的操作任务
SMS 2003 管理包疑难解答
Microsoft System Management Server 2003 管理包参考


此更新中的新增功能

Operations Manager 2007 的 Systems Management Server 2003 管理包包括维护模式。当 SMS 软件在客户端计算机上运行时，维护模式将抑制由客户端计算机发送的 Operations Manager 警报。

更新 SMS 2003 的维护模式

在 System Management Server 2003 将软件分发到计算机时，通常需要临时禁用由目标计算机生成的基于 Operations Manager 规则的警报。例如，在将修补程序和安全修补程序部署到服务器时，可能需要关闭某些线程和服务。如果管理包监视这些服务器上的线程或服务，则可能生成大量 Operations Manager 警报，造成 Operations Manager 服务器负载过多。

如果选中“此程序运行时禁用 MOM 警报”复选框，将暂停生成 Operations Manager 警报，直至软件分发完成为止。SMS 管理员可在 SMS 数据包程序属性中设置此复选框。设置此选项可以在客户端计算机执行该程序时，抑制以客户端计算机为目标的所有管理包的 Operations Manager 警报。

如果选中此选项，当在目标计算机上运行播发时，Operations Manager 代理将处于维护模式。SMS 代理还提供了用于 Operations Manager 代理的超时设置。在目标计算机上运行播发后，SMS 客户端代理将恢复该计算机上的 Operations Manager 代理监视。在此之后，将正常报告任何触发警报的事件。

如果不能在目标计算机上运行软件分发，则将进行以下操作：

  • 如果分发操作返回失败代码，则 SMS 代理将如同分发成功那样，使 Operations Manager 代理退出维护模式。
  • 如果分发操作意外失败，且 SMS 代理在预先设定的超时时间内未接收到失败代码，则 Operations Manager 代理将退出维护模式。

启用 SMS 2003 程序的维护模式

可通过以下步骤在运行 SMS 2003 程序时启用客户端计算机的维护模式。

启用 SMS 2003 程序的维护模式

  1. 在 Systems Management Server 控制台中，依次导航到“Systems Management Server”、“站点数据库/ - <站点服务器名称>、“数据包”。

  2. 在详细信息窗格中，右键单击“程序”，然后单击“属性”。

  3. 在“程序属性”对话框中，单击“MOM”选项卡。

  4. 选中“此程序运行时禁用 MOM 警报”，然后单击“确定”。

在启用 SMS 2003 程序的维护模式后，在分发和运行 SMS 2003 数据包时，客户端计算机将进入维护模式。

注意
在“程序属性”对话框的“要求”选项卡中，可通过选择“最长允许运行时间”属性来设置维护模式的超时时间。

SMS 2003 站点拓扑

Microsoft Operations Manager (MOM) 2005 中的 SMS 2003 层次结构图表已被 SMS 2003 站点层次结构取代。现在，层次结构视图以拓扑图的形式显示服务器角色。

删除的配置脚本

由于 SMS 2003 SP2 或更高版本是推荐使用的 SMS 版本，因此删除了配置脚本。

SMS 2003 报告

SMS 2003 包含一些新的报告，这些报告侧重于不同站点系统角色的性能计数器和不同对象处理计数器的性能计数器，如与 DDR 相关的计数器。有关这些新报告的详细信息，请参阅 SMS 2003 报告。

另请参阅

概念

SMS 2003 报告
SMS 2003 脚本


建议掌握的知识

若要部署和操作 SMS 2003 管理包，建议您掌握以下知识和技能：

  • Operations Manager 2007 监视功能的应用知识。有关 Operations Manager 2007 的详细信息，请访问 Operations Manager 2007 相关网页（网址为：http://go.microsoft.com/fwlink/?LinkID=83259，该网页可能为英文）。
  • 了解 Operations Manager 2007 设计架构以及贵公司使用的设计架构。
  • 熟悉有关 System Center Operations Manager 2007 的部署指南中建议采用的管理包部署过程。
  • SMS 概念和术语的应用知识。有关 SMS 2003 的详细信息，请访问 SMS 2003 产品文档相关网页（网址为：http://go.microsoft.com/fwlink/?linkid=9502，该网页可能为英文）。

另请参阅

概念

管理包监视方案
部署 SMS 2003 管理包

其他资源

执行 SMS 2003 管理包的操作任务


支持的 SMS 配置

SMS 2003 和 Systems Center Operations Manager 2007 的要求在其各自的部署指南中有相关说明。SMS 2003 管理包可监视 SMS 2003。建议使用 SMS 2003 SP2 及更高版本。若要运行 SMS 2003 SP1，则需要运行时间戳脚本。

若要使 Operations Manager 2007 能在软件分发过程中使用维护模式以及使用映射拓扑，则需要安装 SMS 2003 SP3 或更高版本。

此 SMS 2003 管理包不能监视 SMS 1.2、SMS 2.0 或 Configuration Manager 2007。

另请参阅

其他资源

Microsoft System Management Server 2003 管理包参考
SMS 2003 管理包疑难解答


管理包监视方案

Microsoft® Systems Management Server (SMS) 2003 为 SMS 2003 监视提供了新功能和经过改进的功能。以下几节介绍 SMS 2003 管理包支持的主要方案，以及各个方案的功能。

服务可用性

服务发现

可用性监视

状态监视

无代理监视支持

性能阈值监视

性能监视

SMS 关键状态消息监视

站点系统监视

主管服务故障转储监视

积压监视

常规运行状况监视

SMS 修补程序管理监视

SMS 站点备份监视

所有警报的产品知识内容

所有 SMS 2003 服务器和客户端角色的计算机组

扩展监视

软件分发程序运行状态

服务可用性

服务可用性方案同时利用 System Center Operations Manager 2007 的服务可用性功能和 NT 事件系统日志中的服务控制管理器事件，以此来监视 SMS 2003 服务的可用性。服务可用性监视功能将在满足以下条件时生成警报：

  • 当 SMS 站点系统上基于 SMS 的服务停止时。
  • 当 SMS 站点系统上 SMS 关键依赖服务（例如 Windows Management Instrumentation (WMI)）停止或无法启动时。
  • 当 SMS 站点系统上 SMS 依赖的其他服务（例如 Microsoft SQL Server™、Internet Information Services (IIS) 和后台智能传输服务 (BITS)）停止或无法启动时。
  • 当 SMS 站点备份服务启动可停止时生成警报；这样，您就可以监视备份持续时间，并将其他 SMS 服务的停止事件与 SMS 站点备份相关联。

服务发现

服务发现是指发现托管计算机上的数据、服务器角色和组件的过程。服务发现将返回有关 SMS 服务器和 SMS 高级客户端的信息。它还支持在状态监视视图中显示 SMS 服务器和 SMS 客户端角色。

在部署管理包后，将收集特定于服务器的服务发现数据，并开始在系统中心操作控制台中显示这些数据。在第一次收集服务发现数据之前，需要为特定任务标识角色、计算机组和目标计算机的功能将不可用。

SMS 2003 管理包使用以下事件处理规则来启动服务发现脚本：

  • SMS 客户端\SMS 客户端 - 高级\SMS 2003 服务发现
  • SMS 服务器\SMS 服务器 - 公用\SMS 2003 服务发现

默认情况下，这些脚本将使用异步定时提供程序每 24 小时收集一次服务发现数据。提供程序还执行以下任务：

  • 部署管理包
  • 更改管理包配置
  • 启动和停止 Operations Manager 2007 代理

可用性监视

在本版本的 SMS 管理包中，提供了三种可用性报告：SMS 2003 服务器可用性报告、SMS 2003 管理点可用性报告和 SMS 2003 站点服务器可用性报告。

管理点可用性报告是一个基于组件运行状况的可用性报告。管理点可用性基于新的算法、新的规则和 SMS 2003 Monitor Management Point Availability 脚本。

所有报告（包括本节所引用的新报告）将针对 OperationsManager 数据库运行，这允许您指定比先前脚本更长的报告期间。先前的脚本仅在 OperationsManager 数据库中创建存储过程。

有关服务器可用性的详细信息，请参阅SMS 2003 脚本和 SMS 2003 报告。

状态监视

状态监视提供了所有服务器或划分到特定计算机组的服务器的运行状况的图形表示形式。管理包支持对特定的计算机组列表使用此功能。服务器角色和组件通过服务发现来管理，组件的运行状况通过一组服务可用性规则、性能阈值规则和管理点运行状况规则来管理。

下表按颜色列出了所监视的 SMS 组件的运行状况。

SMS 服务器状态监视

SMS 组件 | 绿色 （成功） | 黄色 （警告） | 红色 （关键）
站点服务器 (SS) | 是 | 是 | 是
管理点 (MP) | 是 | 是 | 是
站点数据库 (DB) | 是 | 是 | 是
分发点 (DP) | 是 |  |
服务器定位器点 (SLP) | 是 |  | 是
发送程序 | 是 |  | 是
报告点 (RP) | 是 |  | 是
提供程序 | 是 |  | 是
客户端访问点 (CAP) | 是 |  | 是
性能 | 是 | 是 | 是
注意
由于没有更改分发点组件的状态的监视规则，因此如果存在该组件，其状态只会报告为绿色。如果不存在分发点组件，则控制台中不会显示其运行状态。

SMS 客户端状态监视

SMS 组件 | 绿色 （成功） | 黄色 （警告） | 红色 （关键）
客户端服务 | 是 |  | 是

无代理监视支持

SMS 2003 管理包支持监视无代理托管计算机，但下列功能除外：

  • SMS 关键状态消息监视
  • 站点系统状态监视
  • 拓扑

支持上述功能的脚本包括：

  • SMS 2003 Monitor SMS Status Messages
  • SMS 2003 Monitor Site System Summarizer
  • SMS 2003 Server Topology: Discovery

必须在本地对 SMS 提供程序运行这些脚本，才能访问 SMS 命名空间。如果脚本无法定位 SMS 命名空间，将发生脚本错误事件。

性能阈值监视

如果性能级别下降，可能会造成延迟，并在时间、性能和数据准确性方面影响客户服务级别协议 (SLA)。检测和解决 SMS 基础结构中的关键性能问题非常重要。性能阈值监视功能将在满足下列条件时生成警报：

  • SMS 站点系统上与 CPU、分页文件和内存相关的计算机级常规运行状况度量超过特定阈值。
  • Microsoft SQL Server™ 用户连接总数超过阈值。
  • 在 SMS 站点服务器收件箱中，SMS 文件（例如计划程序作业、发送请求、软件计数记录、发现数据记录 (DDR) 以及软件清单和硬件清单记录）的总数超过特定阈值。
  • 在 SMS 管理点消息队列中，与状态消息、DDR、软件清单和硬件清单相关的 SMS 消息总数超过特定阈值。

性能监视

通过性能监视，您可以监视积压、处理速率和 SMS 关键对象总计数的趋势，以帮助找出问题并主动解决问题。通过使用 Operations Manager 2007 视图和报告，性能趋势以图形方式监视下列趋势：

  • 在 SMS 站点服务器的收件箱中与计划程序作业、发送请求、软件计数记录、DDR、硬件清单、软件清单和状态消息相关的积压文件。
  • 在 SMS 站点服务器上计划程序作业、发送请求、软件计数记录、DDR、硬件清单、软件清单和状态消息的处理速率。
  • 在 SMS 站点服务器上计划程序作业、发送请求、软件计数记录、DDR、硬件清单、软件清单和状态消息的总数。
  • 与 SMS 管理点服务器消息队列中的 DDR、硬件清单、软件清单、软件计数、状态消息和其他 SMS 对象相关的消息积压。
  • SMS 管理点服务器消息队列中的 DDR、硬件清单、软件清单、软件计数、状态消息和其他 SMS 对象的处理速率。
  • SMS 管理点服务器消息队列中的 DDR、硬件清单、软件清单、中继和状态消息的总数。
  • SMS 站点数据库服务器上 SQL Server 用户连接的总数。
  • SMS 站点系统上与 CPU、分页文件和内存相关的计算机级运行状况度量。
  • 当前运行的 SMS 主管服务线程的总数。
  • ISAPI 扩展对 IIS 的请求的速率。

SMS 关键状态消息监视

SMS 基础结构生成 SMS 状态消息。识别与服务器相关的 SMS 关键状态消息并及时解决问题非常重要。这些消息通常指示 SMS 基础结构的可用性、性能、配置和整体运行状况存在的问题。

在检测到对 SMS 站点角色运行状况很重要的状态消息时（例如组件安装、数据库连接和站点连接），SMS 关键状态消息监视功能将生成警报。每半小时将扫描一次 SMS 站点数据库，以查找 SMS 关键状态消息。

站点系统状态监视

SMS 通过其站点系统状态摘要生成器定期监视站点系统的基本运行状况，该摘要生成器每小时一次正点轮询 SMS 站点系统。要从此功能受益，必须迅速对此状态采取措施以防止 SMS 性能降低。站点系统状态监视提供了监视功能，并可在检测到对 SMS 站点系统的运行状况至关重要的 SMS 站点系统摘要生成器状态时生成警报。其中一些被监视的状态消息包括 SMS 站点系统停机，运行 SQL Server 的服务器的数据库空间或日志空间不足，以及 SMS 站点系统的物理磁盘空间不足。

主管服务故障转储监视

SMS 主管服务故障会影响 SMS 可用性，因此了解故障转储的发生时间并调查根本原因非常重要。当 SMS 主管服务发生故障时，它将在 SMS\Logs\CrashDumps 目录下创建一个故障转储日志子目录。创建此子目录的操作会受到监视，并且会为依赖 SMS 主管服务的任何 SMS 服务器角色生成警报。

SMS 2003 Monitor SMS Executive Crash Dumps 脚本仅报告最新的故障转储。无论上次故障转储发生在多久以前（从脚本第一次运行到卸载 SMS 主管服务并在稍后重新安装的任何时候），此规则都适用。

相关规则位于“基于 SMS 主管服务的 Microsoft SMS 2003 组件服务器”规则组下方：

  • SMS 2003 故障转储: 监视 SMS 主管服务

“SMS 2003 故障转储: 监视 SMS 主管服务”使用 SMS 2003“每 60 分钟计划一次，在 00:10 同步”定时事件提供程序来启动脚本。此规则的“知识”属性页上提供了摘要信息。

  • SMS 2003 故障转储: 监视 SMS 主管服务脚本错误

“SMS 2003 故障转储: 监视 SMS 主管服务脚本错误”监视可能发生的任何脚本错误事件并发出警报。只有编号为 1102 的脚本错误事件才会报告所有脚本错误。此规则的“知识”属性页上提供了解决警报的相关信息。

  • SMS 2003 故障转储: SMS 主管服务故障

“SMS 2003 故障转储: SMS 主管服务故障”监视故障转储事件并在事件发生时发出警报。此规则的“知识”属性页上提供了解决警报的相关信息。

积压监视

积压会造成延迟，从而在时间、性能和数据准确性方面影响客户服务级别协议 (SLA)。及时检测和解决 SMS 基础结构中的关键性能问题非常重要。当在给定时间段内下列各项的积压高于阈值时，将生成警报：

  • 在 SMS 站点服务器收件箱中，SMS 文件（例如计划程序作业、发送请求、软件计数记录、发现数据记录 (DDR) 以及软件清单和硬件清单记录）的总数。
  • 在 SMS 站点服务器队列中，SMS 对象（例如计划程序作业、发送请求、软件计数记录、发现数据记录 (DDR) 以及软件清单和硬件清单记录）的总数。

在 SMS 管理点消息队列中，与状态消息、DDR、软件清单和硬件清单相关的 SMS 消息总数。

常规运行状况监视

当在给定时间段内 SMS 服务器上的运行状况度量高于特定阈值时，常规运行状况监视将生成警报。常规运行状况监视将检查下列度量：

  • 处理器时间达到 95%（三小时内）
    • Smsexec
    • Ccmexec
    • Total
  • 分页文件使用率达到 98%（三小时内）

SMS 修补程序管理监视

SMS 管理员依赖于 SMS 修补程序管理功能来保持企业中的客户端和服务器计算机与当前最新的安全更新同步。修补程序管理监视功能将检测 SMS 修补程序管理处理和配置过程中的任何失败。SMS 修补程序管理监视功能将在满足下列条件时生成警报：

  • SMS 修补程序管理同步过程失败。
  • SMS 修补程序管理过程未能使用更新程序来更新 SMS 分发点。

SMS 站点备份监视

了解 SMS 2003 备份何时开始、完成或失败可以帮助 SMS 管理员审核备份活动。可以计划定期运行 SMS 备份来备份 SMS 的数据、策略和配置。监视此备份过程的失败并采取纠正措施非常重要。即使在 SMS 备份成功时，它也会影响服务可用性，因为此过程会停止和启动 SMS 站点组件管理器、SMS 主管服务和 SMS SQL 监视器服务。监视 SMS 备份有助于跟踪这些服务的已知停机时间，因为在备份过程中，将抑制有关这些服务停止的警报。下列规则支持监视 SMS 站点备份：

  • SMS 2003 服务停止运行: SMS_SITE_BACKUP
  • SMS 2003 服务开始运行: SMS_SITE_BACKUP
  • SMS 2003 状态: 站点备份成功完成
  • SMS 2003 状态: 站点备份失败

所有警报的产品知识内容

管理员可参考所有警报的产品知识内容，以帮助找出具体问题并解决问题。要访问产品知识内容，请右键单击任何规则名称，单击“属性”，然后单击“产品知识”选项卡。

所有 SMS 2003 服务器和客户端角色的计算机组

计算机组的解析目前被设置为特定的 SMS 服务器和客户端角色。这将使管理员在管理到 Operations Manager 2007 代理的规则复制时能够更好地进行控制。管理员可以禁用默认的计算机组，还可以根据默认的计算机组和计算机属性来定义新的计算机组。

扩展监视

SMS 2003 管理包中提供的规则涵盖 SQL Server、IIS 和 Microsoft Windows® 2000 以及 Windows Server® 2003 基础操作系统管理包的基本服务、性能测量和性能阈值监视。您可以在 SMS 2003 管理包中为这些管理包启用基础支持，也可以保留被禁用的设置并在其他管理包中启用相应的规则。

  • 可使用 SQL Server 管理包来扩展对依赖于 SQL Server 的 SMS 站点数据库服务器和管理点的监视。
  • 可使用 IIS 管理包来监视报告点、管理点和服务器定位器点上的 IIS。IIS 管理包还可以监视启用了 BITS 的分发点。
  • 可使用 Microsoft Windows 2000 和 Windows Server 2003 基础操作系统管理包来监视 Windows 基本组件，例如 CPU、磁盘和内存统计信息。

还有其他管理包可增强对 SMS 2003 基础结构的监视，对于这些管理包，SMS 2003 管理包未提供规则。

  • 如果您出于可伸缩性的考虑要使用网络负载平衡来支持 SMS 层次结构中的多个管理点，可使用 Windows 网络负载平衡管理包。
  • 可使用 Windows Active Directory® 目录管理包来监视 Active Directory 基础结构的运行状况。

如果您在环境中部署了多个管理包，基于各管理包中存在的规则，您可能会收到冗余警报。如果您禁用冗余监视规则，则可能会影响所部署管理包的状态视图的准确性。在接收冗余警报和使所部署的每个管理包的状态监视正常运行之间，应仔细权衡取舍。根据您所部署的附加管理包，应检查这些冗余规则，以确定需要在您的环境中启用哪些规则。安装这些管理包后，请确认已对其进行了必要的自定义，并且配置正确，启用了适当的规则。

软件分发程序运行状态

SMS 高级客户端可以通过管理包来报告程序的失败。

管理员可以在“程序属性”对话框的“MOM”选项卡上选中“此程序失败时生成 MOM 警报”复选框。

步骤

若要在 SMS 2003 程序失败时启用 Operations Manager 2007 警报，需要执行以下步骤：

为 SMS 2003 程序启用 Operations Manager 2007 警报

  1. 在 Systems Management Server 控制台中，依次导航到“Systems Management Server”、“站点数据库/ - <站点服务器名称>、“数据包”。

  2. 在详细信息窗格中，右键单击“程序”并选择“属性”。随后将打开“程序属性”对话框。

  3. 选择“MOM”选项卡。

  4. 单击“此程序失败时生成 MOM 警报”复选框。单击“确定”。

另请参阅

概念

部署 SMS 2003 管理包

其他资源

Microsoft System Management Server 2003 管理包参考


部署 SMS 2003 管理包

在部署 Microsoft® Systems Management Server (SMS) 2003 管理包之前，请查阅 Operations Manager 2007 网页（网址为：http://go.microsoft.com/fwlink/?LinkID=83259，该网页可能为英文）上有关 Microsoft Operations Manager 2007 的部署指南。本节介绍部署 Operations Manager 管理包的附加说明。

要部署 SMS 2003 管理包，必须完成下列步骤：

  • 将 Operations Manager 2007 代理部署到所有 SMS 服务器组件计算机。
注意
如果需要使用 Operations Manager 2007 维护模式或拓扑映射，则必须在导入 SMS 2003 管理包或安装 Operations Manager 2007 代理之前部署 SMS 2003 SP3。

  • 将 SMS 2003 管理包导入到 Operations Manager 2007 配置组。
  • 配置 SMS 提供程序和 SMS 站点数据库服务器，以便 Operations Manager 2007 代理可以代理其他计算机。
  • 完成建议进行的测试和试验任务。
  • 完成建议进行的优化任务。

本节内容

部署 Operations Manager 2007 代理

管理包测试和试验

自定义管理包

另请参阅

概念

管理包监视方案

其他资源

System Management Server 2003 管理包概述
执行 SMS 2003 管理包的操作任务
SMS 2003 管理包疑难解答
Microsoft System Management Server 2003 管理包参考


部署 Operations Manager 2007 代理

Operations Manager 代理运行在 Operations Manager 所监视的每台计算机上。若要查看 SMS 2003 管理包监视的计算机组，请参阅本指南中的 SMS 2003 计算机组这一节。Operations Manager 2007 代理将收集托管计算机上的监视数据，将规则应用于收集到的数据，并将结果数据发送到 Data Consolidator Agent Manager (DCAM)。代理计算机上的监视功能由 Operations Manager 2007 Service (HealthService.exe)、Operations Manager 2007 Host (MonitoringHost.exe) 和代理操作帐户提供。

若要部署 Operations Manager 2007 代理，可以使用 Operations Manager 2007 安装向导或 SMS 软件分发。有关部署 Operations Manager 2007 代理和使用 Operations Manager 2007 安装向导的详细信息，请参阅 Microsoft Operations Manager 2007 相关部署指南中有关发现计算机和部署 MOM 代理的章节。有关详细信息，请参阅 Operations Manager 2007 相关网页（网址为：http://go.microsoft.com/fwlink/?LinkID=83259，该网页可能为英文）。

注意
建议您使用 LocalSystem 帐户或具有 SMS 2003 WMI 命名空间 root、root\cimv2、root\sms 以及 SMS 注册表项和子项的足够访问权限的帐户，在 SMS 提供程序计算机上运行 Operations Manager 2007 代理。

若要确定您的环境中是否可使用无代理监视，请参阅管理包监视方案中的“无代理监视支持”。

将代理计算机配置为在低权限方案下运行

代理计算机上的监视功能由 Operations Manager 2007 Service (HealthService.exe)、Operations Manager 2007 Host (MonitoringHost.exe) 和代理操作帐户提供。在 Microsoft Windows® 2000 中，操作帐户必须是本地管理员组的成员。在 Microsoft Windows™ 2003 中，在某些情况下可以使用低权限帐户作为代理的“代理操作帐户”。但是，若要配置操作帐户以及 Operations Manager 2007 Service 和 Operations Manager 2007 Host 进程运行的用户上下文，使其拥有足够的权限来运行 SMS 2003 管理包功能，需要在代理计算机上进行大量手动配置。在 Microsoft Windows Server™ 2003 中，代理操作帐户至少必须具有下列用户权限：

  • 本地用户组的成员
  • 访问 Windows 事件日志
  • 管理审核和安全日志权限 (SeSecurityPrivilege)
  • 生成安全审核权限 (SeAuditPrivilege)
  • 允许本地登录权限 (SeInteractiveLogonRight)

在低权限方案中，SMS 2003 管理包要求用作代理操作帐户的帐户具有一些其他权限。下表详细介绍了必须手动配置的访问权限。

SMS 2003 管理包所需的访问权限类型

资源 | 权限类型 | 说明
Windows 事件日志 | 读 | 必须通过本地或全局策略为操作帐户授予“管理审核和安全日志”权限。
SMS 注册表项 | 读 | HKLM\Software\Microsoft\SMS 将操作帐户添加到注册表属性中，并提供所有子项继承的读权限。
Win32 服务注册表项 | 读 | HKLM\System\CurrentControlSet\Services 将操作帐户添加到本地用户组中。
脚本生成的临时文件 | 读和写 | %Windir%\Temp 将操作帐户添加到本地用户组中。 .
脚本生成的日志文件 | 读和写 | %Windir%\Microsoft Operations Manager 将操作帐户添加到文件夹属性中。
SMS 日志文件 | 读 | \SMS\Logs 将操作帐户添加到文件夹属性中。
WMI 命名空间 | 读 | root 和 root\cimv2 不需要执行任何操作。
SMS WMI 命名空间 | 读 | 不需要执行任何操作。
SMS WMI 类 | 读 | SMS_Site SMS_R_System SMS_SystemResourceList SMS_SiteSystemSummarizer 将操作帐户添加到所有实例的类中。
默认实例的安全登录权限 | 授予访问权限 | 对于 SQL Server 托管计算机上的默认实例，必须为操作帐户授予“授予访问权限”权限，以进行安全登录。在 SQL Server 企业管理器中，将操作帐户添加到以下节点中：instancename\Security\Logins。
默认实例上的主数据库的访问权限（必须有此访问权限才能识别 SMS 站点数据库） | 许可 | 对于 SQL Server 托管计算机上的默认实例，必须为操作帐户授予“许可”权限，以便访问主数据库。在 SQL Server 企业管理器中，将操作帐户添加到以下节点中：instancename\Databases\Master\Users。 保留与该新用户相关的所有默认权限。
默认实例上的 SMS 站点数据库的访问权限 | 许可 | 对于 SQL Server 托管计算机上的默认实例，必须为操作帐户授予“许可”权限，以便访问 SMS 站点数据库。在 SQL Server 企业管理器中，将操作帐户添加到以下节点中：instancename\Databases\<SMS site>\Users。 保留与该新用户相关的所有默认权限。

另请参阅

概念

管理包测试和试验
自定义管理包
SMS 2003 的已知问题

其他资源

SMS 2003 管理包疑难解答


管理包测试和试验

除了有关 Microsoft Operations Manager 2007 的部署指南中建议执行的管理包常规测试任务，本节列出适用于 SMS 2003 管理包的测试和初步试验任务。有关详细信息，请参阅 Operations Manager 2007 相关网页（网址为：http://go.microsoft.com/fwlink/?LinkID=83259，该网页可能为英文）。

测试任务

  • 验证 SMS 2003 计算机组是否由运行 SMS 2003 的计算机组成。
  • 在启用相关规则后，确保 Operations Manager 2007 中的视图和报告能正常运行。这包括与 SMS 处理速率和 SMS 积压相关的视图。
  • 默认情况下，与诸如 IIS 和 SQL Server 管理包等其他管理包相关的一些规则，在 SMS 2003 管理包中是禁用的。根据您所部署的附加管理包，应检查这些禁用的规则，以确定需要在您的环境中启用哪些规则。
  • 默认情况下，将禁用所有性能测量规则，以最大限度降低对代理的 CPU、内存和网络资源的影响。可以启用这些规则，以对代理进行更深入的监视。
  • 对于某些在 SMS 提供程序计算机和 SMS 站点数据库服务器上运行或访问 SMS 站点数据库的 SMS 脚本，它们没有在无代理模式下运行。验证 Microsoft SMS 2003 提供程序和 Microsoft SMS 站点数据库服务器这两个计算机组中的所有计算机是否都已配置为代理托管计算机。此外，由于其中一些脚本可能要执行代理事件，因此需要验证这些代理是否已配置为启用代理。

试验任务

  • 验证 SMS 2003 管理包是否已部署成功或从上一版本成功升级。
  • 通过性能阈值的“运行状况监视器”视图来验证和编辑环境的自定义阈值。
  • 分阶段启用性能规则，以评估这些规则对 Operations Manager 2007 性能的影响。
  • 验证 SMS 2003 计算机组是否由运行 SMS 2003 的计算机组成。
  • 在启用相关规则后，确保 Operations Manager 2007 中的视图和报告能正常运行。这包括与 SMS 处理速率、处理总数和 SMS 积压相关的视图。
  • 默认情况下，将禁用与其他管理包相关的规则。根据您所部署的附加管理包，应检查这些禁用的规则，以确定需要在您的环境中启用哪些规则。
  • 默认情况下，将禁用某些性能规则，以最大限度降低对代理的 CPU、内存和网络资源的影响。可以启用这些规则，以对代理进行更深入的监视。
  • 验证是否生成基于 SMS 2003 脚本执行的事件。这些事件通常表示脚本的访问权限出现问题。
  • 验证 DCAM 和 SQL Server 的容量是否足以应付生产负载。
  • 验证是否符合操作流程和人员要求。
  • 验证分页和电子邮件通知是否能正常运行。
  • 验证 Operations Manager 2007 所使用的权限是否足以保证正常运行，而不至于太多。
  • 如果未将 Operations Manager 2007 代理指定为在 LocalSystem 帐户下运行，则应确保满足最低的安全权限。有关详细信息，请参阅本指南的部署 Operations Manager 2007 代理小节中的“将代理计算机配置为在低权限方案下运行”。
  • 验证 SMS 服务器和 SMS 客户端角色是否显示在“状态”视图中。单击承载上述每个角色的计算机，确认其组件显示在实例窗格中。
  • 通过单击 SMS 管理员控制台任务来验证该任务是否运行正常。如果该任务无法执行，请检查是否安装了 SMS 2003 SP2 管理员控制台，并检查先前登录的用户是否已注销，并在完成控制台安装后重新登录。
  • 在“状态”视图中，单击 SMS 服务器或 SMS 客户端，验证“角色”页面是否显示相应的角色和属性数据。
  • 在“监视”窗格中，导航到“Microsoft Systems Management Server (SMS) 2003”，然后单击“SMS 2003 站点层次结构图表”。对于 Operations Manager 2007 代理安装在其 SMS 提供程序本地的站点，验证是否所有站点系统都能显示出来。如果未显示某个站点系统，请检查 SMS 管理员控制台，以查看该站点是否已发现该站点系统，并显示在“所有系统”集合中。

在完成试验后，导出 SMS 2003 管理包，以备份对其进行的更改。

另请参阅

概念

自定义管理包
部署 Operations Manager 2007 代理
SMS 2003 的已知问题

其他资源

SMS 2003 管理包疑难解答


自定义管理包

可根据贵公司的业务需要自定义 SMS 2003 管理包，从而实现最佳监视效果。如果现有规则不能满足贵公司的要求，可以对其进行修改或创建新的规则。

注意 应始终在进行更改之前备份 SMS 2003 管理包。可通过 Operations Manager 2007 管理包导出向导来备份未密封的管理包。

自定义操作可包括下列任一操作：

  • 使用替代来启用和禁用规则。
  • 创建新的规则。
  • 修改警报条件、警报严重性和警报抑制。
  • 设置规则的自定义阈值。所有性能阈值规则都是可配置的。如果默认阈值不是最佳设置，则可能收到不必要的警报，或可能因阈值设置过高，不适用于您的环境，从而导致收不到警报。
  • 通过替代来配置收件箱监视事件规则阈值和轮询间隔；如果是配置阈值，则可通过编辑 XML 视图来完成。
  • 添加新的收件箱监视事件规则。若要添加新的收件箱监视规则，可在“默认管理包”中创建新规则，然后为脚本输入参数（FileCountThreshold 和 InboxDirectoryName）和计划创建替代。
  • 通过替代来设置性能测量的轮询间隔。
  • 将内容添加到公司知识中。
  • 更改或添加新的规则响应或者为警报添加处理规则，以此来自定义警报的响应。
  • 在运行 Operations Manager 2007 的服务器代理上启用性能测量规则。如果启用，数据库将生成大量数据，并可能造成性能问题。默认情况下，将禁用性能测量规则，以便您确定是否可以接受可能造成的性能影响。可检查性能规则，并小批量启用这些规则，这样就可以评估这些规则对 Operations Manager 2007 性能（包括数据库的大小）的影响。
  • 设置收件箱监视事件规则和相关规则的参数。通过创建替代来修改 FileCountThreshold 和 InboxDirectoryName, 这两个参数。
  • 检查规则是否适用于您的环境。默认情况下，将禁用与其他管理包相关的规则。根据您所部署的附加管理包，应检查这些禁用的规则，以确定需要在您的环境中启用哪些规则。

有关管理包自定义和如何导出管理包自定义的详细信息，请参阅 Operations Manager 2007 帮助中有关 Operations Manager 2007 中的管理包和如何导出管理包自定义的主题。

收件箱监视

利用 Operations Manager 2007 导出向导，可以在进行其他更改之前保存默认管理包中的更改。

配置收件箱监视规则

若要将这些规则部署到中央站点服务器、主站点服务器和辅助站点服务器，则必须根据“SMS 站点服务器 - 公用”中的规则在管理包中创建新规则。然后，可以将这些规则指派到站点服务器的相应处理规则组中，并修改阈值和启用规则。

  • SMS 2003 收件箱: 监视收件箱
  • SMS 2003 收件箱: 监视收件箱脚本错误
  • SMS 2003 收件箱: 超过阈值

“SMS 2003 收件箱: 超过阈值”事件处理规则将监视“SMS 2003: 监视收件箱脚本错误”脚本。对于超过指定的阈值计数的每个收件箱，都会生成一个唯一的警报。

该脚本的默认阈值设置是每个收件箱中最多容纳 10,000 个文件。可以在默认管理包中为此参数或任何其他脚本参数创建该值的替代值。如果超过了该值，将引发“超过阈值”事件。可以通过计算服务器上每个正常运行的进程的每日预期负载，然后增加可接受的缓冲百分比来修改该阈值设置。默认情况下，收件箱监视规则每天运行一次，在 01:00 开始，各个规则依次错开 15 分钟运行。为了最大限度降低性能影响，建议您保留此间隔，或调整此间隔，以尽可能减少收件箱监视规则之间的脚本执行时间重叠。

下表中列出了收件箱监视规则、默认阈值和 SMS 主管服务提供程序所监视的收件箱。

SMS 主管服务收件箱监视

收件箱监视规则名称 | 默认阈值 | 收件箱名称
SMS 2003 收件箱: 监视收件箱脚本错误 | n/a | n/a
SMS 2003 收件箱: 超过阈值 | n/a | n/a
SMS 2003 收件箱: 监视 auth\dataldr.box | 10000 | Inboxes\auth\dataldr.box
SMS 2003 收件箱: 监视 auth\ddm.box | 10000 | Inboxes\auth\ddm.box
SMS 2003 收件箱: 监视 auth\sinv.box | 10000 | Inboxes\auth\sinv.box
SMS 2003 收件箱: 监视 compsumm.box\repl | 10000 | Inboxes\ compsumm.box\repl
SMS 2003 收件箱: 监视 dataldr.box | 10000 | Inboxes\ dataldr.box
SMS 2003 收件箱: 监视 ddm.box | 10000 | Inboxes\ ddm.box
SMS 2003 收件箱: 监视 despoolr.box\receive | 10000 | Inboxes\despoolr.box\receive
SMS 2003 收件箱: 监视 offermgr.box\INCOMING | 10000 | Inboxes\offermgr.box\INCOMING
SMS 2003 收件箱: 监视 offersum.box\repl | 10000 | Inboxes\ offersum.box\repl
SMS 2003 收件箱: 监视 replmgr.box\incoming | 10000 | Inboxes\replmgr.box\incoming
SMS 2003 收件箱: 监视 schedule.box\outboxes\LAN | 10000 | Inboxes\ schedule.box\outboxes\LAN
SMS 2003 收件箱: 监视 statmgr.box\statmsgs | 10000 | Inboxes\statmgr.box\statmsgs
SMS 2003 收件箱: 监视 swmproc.box\usage | 10000 | Inboxes\swmproc.box\usage

替代收件箱监视事件规则的步骤

在替代收件箱监视事件规则前，Operations Manager 2007 站点服务器必须发现类型为“Microsoft SMS 2003 站点服务器”的 SMS 2003 站点服务器对象。

替代收件箱监视事件规则

  1. 在 Operations Manager 2007 操作控制台中，单击“创作”按钮。

  2. 导航到“创作”、“管理包对象”、“规则”。

  3. 将范围指定为“Microsoft SMS 2003 站点服务器”。

  4. 右键单击相应的 SMS 2003 收件箱监视事件规则，如揝MS 2003 收件箱：监视 schedule box\requests”，选择“替代”、“替代规则”，然后单击“对于类型为 Microsoft SMS 2003 站点服务器的所有对象”。

  5. 在“替代属性”中选中“已启用”替代复选框，并将“替代设置”设为“True”。

  6. 在“替代属性”中选中“文件数阈值”替代复选框，并将“替代设置”设为所需的阈值。

  7. 单击“确定”。单击“确定”。修改后的阈值将分发到服务器。

编辑性能计数器阈值监视的步骤

若要编辑性能计数器阈值监视，请执行以下步骤：

编辑性能计数器阈值监视

  1. 在 Operations Manager 2007 操作控制台中，单击“创作”按钮。

  2. 导航到“创作”、“管理包对象”、“监视器”。

  3. 将范围更改为“SMS 服务器”。

  4. 导航到“SMS 服务器”、“实体运行状况”、“MOM 2005 计算机角色运行状况”，然后选择相应的计算机角色，如“SS”表示站点服务器。

  5. 双击要编辑的性能阈值监视规则。随后将打开“性能阈值属性”对话框。

  6. 选择“配置”选项卡。

  7. 单击“编辑...”。随后将打开“Xml 配置”对话框。

  8. 在 XML 文本中，编辑要修改的阈值。

    • 指定 <CriticalErrorExpression> 中嵌套的 <ValueExpression>，更改严重错误阈值。
    • 指定 <WarningExpression> 中嵌套的 <ValueExpression>，更改警告阈值。

  9. 单击“确定”。单击“确定”。修改后的阈值将分发到服务器。

另请参阅

概念

管理包测试和试验
支持的 SMS 配置
管理包监视方案

其他资源

SMS 2003 管理包疑难解答
Microsoft System Management Server 2003 管理包参考


执行 SMS 2003 管理包的操作任务

建议您及时查看和解决所有警报，以确定比较重要或可能比较严重的警报。此外，还应根据您的环境，定期执行其他任务。很多重要问题不会导致警报，但仍需要定期关注这些问题。Microsoft® Systems Management Server (SMS) 2003 管理包提供视图和报告，这些视图和报告按时间显示数据，并提供样式以提示出现的问题。请查看视图和报告以解决问题，避免生成警报。

应按本节中的说明，执行每日、每周和每月任务，但可以调整执行这些任务的频率，以满足特定环境的需要。

本节内容

SMS 2003 每日任务

SMS 2003 每周任务

SMS 2003 每月任务

SMS 2003 管理员控制台任务

另请参阅

概念

管理包监视方案
部署 SMS 2003 管理包

其他资源

System Management Server 2003 管理包概述
执行 SMS 2003 管理包的操作任务
SMS 2003 管理包疑难解答
Microsoft System Management Server 2003 管理包参考


SMS 2003 每日任务

建议您每日执行下列任务：

  • 查看所有未解决的警报。
  • 查看计算机组成员身份。
  • 验证是否所有 Operations Manager 2007 代理都在与 Operations Manager 2007 服务器通信。
  • 查看性能积压。
  • 查看性能处理速率。
  • 查看 Operations Manager 2007 代理和服务器性能。
  • 查看通知组成员身份或事件处理规则通知组。
  • 查看 SMS 2003 站点积压。
  • 查看事件（可选）。

查看所有未解决的警报

在 SMS 2003 管理包中，将使用以下警报描述格式显示警报：

$Computer$ <Rule Name>

$Description$

Event details

查看 Operations Manager 2007 中的所有警报以确保它们得到及时处理。您可以使用以下任一方式来查看未解决的警报：

  • 在操作控制台中，单击“监视”按钮，展开“Microsoft Systems Management Server (SMS) 2003”，然后单击“警报”。
  • 在操作控制台中，单击“监视”按钮，展开“Microsoft Systems Management Server (SMS) 2003”，然后单击“常规”。选择“最近 72 小时内的新警报”。
  • 可通过单击“计算机和组”按计算机或计算机组来查看警报。要按警报的严重性显示摘要，请右键单击要检查的 SMS 2003 计算机组，选择“查看”，然后单击“警报”。
  • 可通过“状态”视图查看警报。“状态”视图显示计算机列表以及严重程度最高的警报。双击任意计算机可获取其当前警报的列表。
  • 可通过“图表”视图查看警报。SMS 2003 层次结构“图表”视图显示了 SMS 2003 层次结构的图形表示形式。每台计算机都有一个状态注释，指示其严重程度最高的警报。双击任意计算机可获取其当前警报的列表。

建议您按下列顺序查看所有新增警报：

  1. SMS 2003 核心服务警报
  2. SMS 2003 依赖服务警报
  3. 基于 SMS 2003 站点系统状态摘要生成器的警报
  4. SMS 2003 管理点运行状况警报
  5. 基于 SMS 2003 状态消息的警报
  6. SMS 2003 组件警报
  7. SMS 2003 积压警报
  8. SMS 2003 收件箱监视警报
  9. SMS 2003 SMS 站点备份失败警报
  10. SMS 2003 程序失败警报

查看计算机组成员身份

可使用 Operations Manager 2007 来验证计算机组成员身份。

  • 在操作控制台中，单击“创作”按钮，单击“组”，然后右键单击相应的 SMS 2003 计算机组。验证所显示的每个计算机组是否包含正确的计算机。

验证代理是否在与 Operations Manager 2007 服务器通信

如果代理与监视基础结构之间通信失败，将无法接收警报。通过运行可用性报告，验证代理是否在与运行 Operations Manager 2007 的服务器通信。有关详细信息，请参阅 Operations Manager 2007 帮助中有关如何在 Operations Manager 2007 中创建可用性报告的主题。

查看性能积压和性能处理速率

性能积压和性能处理速率对于检测每日趋势和了解 SMS 层次结构中发生的事件非常有用。可在 Operations Manager 2007 中查看性能积压和性能处理速率。

查看性能积压

要查看性能积压，请执行下列步骤：

查看性能积压

  1. 在操作控制台中，单击“监视”按钮，然后展开“Microsoft Systems Management Server (SMS) 2003”。

  2. 依次展开“性能”、“积压”。接着，单击相应的组件子文件夹。可使用计数器选项减少所显示的数据、计算机数量，还可以只选择所需的计算机。

查看性能处理速率

要查看性能处理速率，请执行下列步骤：

查看性能处理速率

  1. 在操作控制台中，单击“监视”按钮，然后展开“Microsoft Systems Management Server (SMS) 2003”。

  2. 依次展开“性能”、“积压”。接着，单击相应的组件子文件夹。可使用计数器选项减少所显示的数据、计算机数量，还可以只选择所需的计算机。

SMS 2003 站点备份监视

应根据需要在您的企业环境中启用 SMS 站点备份维护任务并计划备份。SMS 站点备份服务启动后，它首先将停止所有 SMS 服务，包括 SMS_EXECUTIVE、SMS_SQL_MONITOR 和 SMS_SITE_COMPONENT_MANAGER。在下列条件下，SMS 站点备份进程不支持运行时备份：

  • 将 SMS 安装文件夹的部分内容复制到备份导出路径。
  • 备份各种 SMS 注册表值。
  • 在运行 Microsoft SQL Server™ 的服务器上备份 SMS 站点数据库。

备份完成后，SMS 站点备份服务将重新启动 SMS 服务。在备份过程中，这些服务停止和启动是正常的，并不表示发生了任何严重错误。在 SMS 站点备份过程中，将抑制这些服务停止应产生的警报。您可以将这些服务停止和启动以及 SMS 站点备份停止和启动关联起来。为此，应启用下列规则。当 SMS 站点备份服务启动或停止时，这些规则将引发提示性警报：

  • SMS 2003 服务停止运行: SMS_SITE_BACKUP
  • SMS 2003 服务开始运行: SMS_SITE_BACKUP

当 SMS 站点备份服务无法启动或异常停止时，将引发下列警报：

  • SMS 2003 服务故障: SMS_SITE_BACKUP 异常终止
  • SMS 2003 服务故障: SMS_SITE_BACKUP 在启动时挂起
  • SMS 2003 服务故障: SMS_SITE_BACKUP 无法启动
  • SMS 2003 服务故障: SMS_SITE_BACKUP 无法登录
  • SMS 2003 服务故障: SMS_SITE_BACKUP 依赖于另一服务，但该服务无法启动或不存在。

如果您看到一条指示服务异常终止的警报，请验证是否已重新启动所有停止的服务。SMS 站点备份服务可能在重新启动这些服务之前已经终止。

下面的状态消息警报显示备份过程是否成功：

  • SMS 2003 状态: 站点备份成功完成
  • SMS 2003 状态: 站点备份失败

备份失败的原因可能包括：访问权限问题、磁盘空间不足、无法启动或停止某些服务或者 SQL Server 操作失败。

查看事件

应定期查看事件，因为它们指示了非关键性的失败，并有助于深入了解 Operations Manager 2007 代理的运行状况。

查看事件

要查看事件，请执行下列步骤：

查看事件

  1. 在操作控制台中，单击“监视”按钮。

  2. 展开“Microsoft Systems Management Server (SMS) 2003”，然后单击“事件”。

另请参阅

概念

SMS 2003 每周任务
SMS 2003 每月任务
SMS 2003 管理员控制台任务

其他资源

执行 SMS 2003 管理包的操作任务
SMS 2003 管理包疑难解答
Microsoft System Management Server 2003 管理包参考


SMS 2003 每周任务

除了每天执行的任务外，还可以按周执行以下任务：

  • 查看报告。有关 SMS 2003 管理包中包含的报告的列表，请参阅本指南中的 SMS 2003 报告 这一节。
  • 查看过去一周的警报、事件和性能，以发现潜在问题和趋势。
  • 如果需要，可以调整 Operations Manager 2007 配置设置，如 Operations Manager 2007 代理检测信号间隔、服务监视状态检查间隔、代理管理器检测信号扫描间隔、发现间隔和数据库整理参数等。
  • 查看 SMS 站点的备份历史记录。
  • 查看 SMS 2003 的 Operations Manager 2007 配置组的备份历史记录。
  • 查看 SQL Server 数据库和日志。
  • 运行 SMS 2003 可用性报告，以了解 SMS 服务器及其组件的可用性。
  • 通过 SMS 2003 层次结构图表来检查您的 SMS 层次结构。

另请参阅

概念

SMS 2003 每日任务
SMS 2003 每月任务
SMS 2003 管理员控制台任务

其他资源

执行 SMS 2003 管理包的操作任务
SMS 2003 管理包疑难解答
Microsoft System Management Server 2003 管理包参考


SMS 2003 每月任务

除每天和每周执行的任务之外，还需每月检查下列类别的数据。

最常见的警报和事件

  • 最常见的警报
  • 最常见的事件
  • 最常见的警报和事件（按规则组）
  • 最常见的警报和事件（按 SMS 2003 组件）
  • 最常见的警报和事件（按 SMS 2003 功能）

可以制定一个操作计划来减少警报数和事件数。

SMS 积压监视

  • 查看各种站点系统上与积压趋势相关的报告。

SMS 积压趋势

  • 查看与积压相关的报告，以确保在 SMS 站点系统上积压数没有长期向上的趋势，并且不存在影响服务级别协议 (SLA) 的不可接受水平的积压。

SMS 性能趋势：总计和处理速率

  • 发现数据记录
  • 硬件清单
  • 软件清单
  • 软件计数
  • 状态消息

常规系统性能

  • 磁盘使用
  • 内存使用
  • 处理器使用

SMS 服务可用性

  • SMS_EXECUTIVE
  • SMS 代理主机服务
  • SMS 客户端服务
  • SMS_REPORTING_POINT
  • SMS_SERVER_LOCATOR_POINT
  • SMS_SQL_MONITOR
  • SMS_SITE_COMPONENT_MANAGER

SMS 可用性

  • 运行 SMS 2003 可用性报告可查看 SMS 服务器和 SMS 组件的可用性。

另请参阅

概念

SMS 2003 每日任务
SMS 2003 每周任务
SMS 2003 管理员控制台任务

其他资源

执行 SMS 2003 管理包的操作任务
SMS 2003 管理包疑难解答
Microsoft System Management Server 2003 管理包参考


SMS 2003 管理员控制台任务

要执行 SMS 管理员控制台任务，需要在安装了 Operations Manager 2007 操作控制台的相同计算机上安装 Microsoft Systems Management Server (SMS) 2003 SP2 或更高版本的管理员控制台。安装完 SMS 管理员控制台后，必须注销并重新登录 Windows，然后才能启用任务功能。

管理包任务

任务 | 描述
SMS 管理员控制台 | 打开指向当前所选计算机上的 SMS 管理员控制台。此任务适用于承载 SMS 站点服务器角色的计算机。
所有 SMS 状态消息 | 系统将提示计算机的站点服务器，打开 MMC 窗口，执行状态消息查询，以返回与当前所选计算机相关的所有状态消息。此任务适用于所有系统。
SMS 服务管理器 | 打开指向当前所选计算机的 SMS 服务管理器。此任务适用于承载 SMS 站点服务器角色的计算机。
SMS 资源浏览器 | 系统将提示计算机的站点服务器，打开 MMC 窗口，其中的 SMS 资源浏览器显示了当前所选计算机的相关数据。此任务适用于所有系统。

另请参阅

概念

SMS 2003 每日任务
SMS 2003 每周任务
SMS 2003 每月任务

其他资源

执行 SMS 2003 管理包的操作任务
SMS 2003 管理包疑难解答
Microsoft System Management Server 2003 管理包参考


SMS 2003 管理包疑难解答

您可以采取许多措施来解决产品问题：

  • 确保已正确安装 Operations Manager 2007。
  • 确保已正确设置 Operations Manager 2007 配置设置。
  • 确保已根据操作管理信息配置所有 Microsoft® Systems Management Server (SMS) 系统。
  • 确保所有托管的 SMS 提供程序和 SMS 站点数据库计算机都已安装 Operations Manager 2007 代理，并已启用为其他计算机的代理。
  • 确保已成功导入完整的管理包。
  • 确保已启用所有相关实体，如规则和相关警报。
  • 确保计算机组由正确的计算机组成。可使用“视图”来进行此项检查。
  • 确保不存在检测信号失败警报。
  • 确保已正确设置检测信号间隔，并已将规则传播到 Operations Manager 2007 代理计算机。
  • 确保 Windows Management Instrumentation (WMI)、World Wide Web 发布服务、Internet Information Services (IIS) Admin 服务、后台智能传输服务 (BITS) 和 MSSQLServer 等依赖服务都已在 SMS 2003 站点系统上正确安装和正常运行。
  • 确保不存在由于警报生成过多、语法错误或脚本运行时间过长等原因被 Operations Manager 2007 自动禁用的规则。
  • 确保已正确安装所有性能计数器。

本节内容

SMS 2003 的已知问题

另请参阅

概念

管理包监视方案
部署 SMS 2003 管理包

其他资源

System Management Server 2003 管理包概述
执行 SMS 2003 管理包的操作任务
Microsoft System Management Server 2003 管理包参考


SMS 2003 的已知问题

以下是 Operations Manager 2007 的 Systems Management Server 2003 管理包的一些已知问题。

需要安装 SMS 2003 SP3 才能使用维护模式和查看拓扑图

SMS 可能影响终止 WMI 服务的非 Microsoft 软件的安装

WMI 监视

SMS 任务只能在用于安装 SMS 2003 管理员控制台的用户上下文中运行

如果在同一台计算机上安装了 SMS 管理员控制台，SMS 2003 管理包无法检测到 SMS 辅助站点

系统重新启动

SMS 2003 Monitor SMS Status Messages 脚本

SMS 2003 Monitor Site Summarizer 脚本偏离默认站点系统状态摘要生成器间隔

监视发送程序连接性的状态消息规则依赖于发送程序的功能

默认情况下，BITS 监视是禁用的

应用程序提供程序的路径默认设为 C:\SMS\Logs，此路径对某些 SMS 站点服务器可能无效

需要安装 SMS 2003 SP3 才能使用维护模式和查看拓扑图

SMS 2003 站点服务器上需要安装 SMS 2003 SP3 才能在 Operations Manager 2007 中启用维护模式或查看站点拓扑。有关详细信息，请参阅 支持的 SMS 配置。

SMS 可能影响终止 WMI 服务的非 Microsoft 软件的安装

SMS 2003 管理包可能会影响需要访问 WMI 服务的非 Microsoft 软件的安装。管理包的大多数脚本使用 WMI 来访问注册表，并可以重新启动 WMI 服务。如果 WMI 服务已启用并且可以启动，则组件对象模型 (COM) 可以成功重新启动 WMI。

如果非 Microsoft 软件停止，但未在安装或升级过程中禁用 WMI，则 WMI 脚本的自动重新启动可能会影响非 Microsoft 软件的成功安装。在安装程序未先禁用 WMI 服务的情况下，这可能导致 WMI 或 WMI 提供程序升级出现问题。此问题适用于 WMI 的任何客户端。

WMI 监视

  • 以下规则基于服务控制管理器的 Windows NT® 系统事件日志来监视意外的服务故障。对于这些规则，无任何已知的操作系统限制。
  • SMS 2003 依赖服务故障: Windows Management Instrumentation 异常终止。
  • SMS 2003 依赖服务故障: Windows Management Instrumentation 在启动时挂起。
  • SMS 2003 依赖服务故障: Windows Management Instrumentation 无法启动。
  • SMS 2003 依赖服务故障: Windows Management Instrumentation 无法登录。
  • SMS 2003 依赖服务故障: Windows Management Instrumentation 依赖于另一服务，但该服务无法启动或不存在。

SMS 任务只能在用于安装 SMS 2003 管理员控制台的用户上下文中运行

出现这一问题是因为 SMS 管理员控制台安装过程所创建的 SMS_UI_PATH 环境变量是一个用户环境变量，而不是系统环境变量。要解决此问题，您可以复制 SMS_UI_PATH 的名称和值，并将上述变量定义为系统环境变量，这样，所有操作员和管理员都可以成功地调用任务。

如果在同一台计算机上安装了 SMS 管理员控制台，Systems Management Server 2003 管理包无法检测到 SMS 辅助站点

如果在同时作为 SMS 辅助站点服务器的计算机上安装 Systems Management Server 2003 管理员控制台，则 SMS 2003 管理包无法将该服务器识别为 SMS 辅助站点服务器。

为解决此问题，在 SMS 辅助站点服务器上安装 SMS 管理员控制台后，需要将注册表值 HKLM\SOFTWARE\Microsoft\SMS\Setup\Type 由 4 更改为 2。

系统重新启动

系统重新启动时，您可能只会收到几条有关服务停止的警报。不会有任何事件或警报指明系统被重新启动。检测系统正常或异常关闭的最佳解决方案是安装 Microsoft Windows Servers 基础操作系统管理包，其中包含的规则可提示您系统重新启动。确定系统是否重新启动的其他方法包括查看 SMS 日志、Operations Manager 2007 NT 事件日志、Windows NT 事件日志以及 Operations Manager 2007 事件中的代理通信。

SMS 2003 Monitor SMS Status Messages 脚本

当 SMS 状态消息表中的消息数超过 4,294,967,296 条时，记录 ID 将从零重新开始。SMS 2003 Monitor SMS Status Messages 脚本没有检测机制来检测记录 ID 何时从零重新开始。目前，该脚本只是从它所处理的最后一条状态消息的记录 ID 开始向前查找。如果该记录 ID 重新开始，则管理包无法检测到任何新的状态消息。

在站点服务器上，记下“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER”注册表项中的 Next Status Message Record ID 注册表值。该值是位于 SQL StatusMessages 表中的下一条记录 ID。如果该值小于 LastRecordID 值，则表示 StatusMessages 表已循环并重新开始。在 Next Status Message Record ID 注册表值大于 VarSet 文件中的 LastRecordID 值后，该脚本才会重新开始处理消息。

您应该定期监视站点服务器上的 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER 注册表项中下一条状态消息的记录 ID。在 SMS 层次结构中处于较低层次的小型组织或站点应每隔一两个月检查一次该注册表项。具有多个子站点的大型组织或站点应每月检查一次该注册表项。如果值接近 4,294,967,296，则应更频繁地监视该注册表项。记录 ID 重置为零后，您必须取消阻止对运行站点的 SMS 站点数据库服务器的计算机进行状态消息监视。SMS 站点数据库的位置在安装 SMS 时指定。

自动监视注册表项的一种方法是，创建一个计算机属性和计算机组来监视接近此阈值的计算机。

查找配置组中的所有 SMS 站点数据库

  1. 在操作控制台中，单击“创作”按钮。
  2. 在结果窗格中，右键单击“Microsoft Systems Management Server (SMS) 2003”，然后选择“查看组成员”。

取消阻止状态消息监视

  1. 在承载 SMS 站点数据库角色的计算机上，打开 Windows Temp 文件夹中的以下文本文件：SMS 2003 Monitor SMS Status Messages.VarSet。LastRecordID_[SMSDatabaseName] 条目是指明 SQL StatusMessages 表中脚本所处理的最后一条状态消息的记录 ID 值。
  2. 在承载 SMS 站点数据库角色的计算机上，将名为 SMS 2003 Monitor SMS Status Messages.VarSet 的文件中相应站点的 LastRecordID_[SMSDatabaseName] 值更改为等于 Next Status Message record ID 注册表值减一。如果结果为 4,294,967,296，请将该值设置为零并保存文件。

SMS 2003 Monitor Site Summarizer 脚本偏离默认站点系统状态摘要生成器间隔

站点系统状态摘要生成器的轮询每隔一小时正点运行，SMS 2003 Monitor Site System Summarizer 脚本的间隔则与此偏离 10 分钟。虽然 SMS 管理员控制台允许配置站点系统状态摘要生成器计划，但它不会更改此轮询间隔，而只会更改其他维护任务的时间间隔。SMS 2003 Monitor Site System Summarizer 脚本是通过定时事件提供程序“每 60 分钟计划一次，在 00:10 同步”运行的。通过偏离 10 分钟，可以留出足够的时间让站点系统状态摘要生成器完成其运行周期。如果这段时间不够，应予以延长，否则该脚本将在站点系统摘要生成器完成其运行周期之前完成。这可能会导致报告旧的站点系统状态。

监视发送程序连接性的状态消息规则依赖于发送程序的功能

如果发送程序无法连接到其父站点，则状态消息无法向上流动到 SMS 层次结构，管理包不会为这些状态消息生成警报。这对于辅助站点尤为重要，辅助站点不运行 SMS 2003 监视状态消息脚本。下列监视发送程序连接性的状态消息规则依赖于发送程序的功能，默认情况下，这些规则是禁用的：

  • SMS 2003 状态: 发送程序无法通过 LAN (标准安全)连接到远程站点。
  • SMS 2003 状态: 发送程序无法通过 RAS 连接到远程站点。
  • SMS 2003 状态: 发送程序无法通过 LAN (高级安全)连接到远程站点。
注意
默认情况下，所有这些规则都是禁用的。为使这些规则起作用，每一台 SMS 站点数据库服务器或者至少中央站点必须是托管计算机。

已基于一个应用程序日志提供程序（即 SMS 2003 发送程序日志）提供了一种并行监视方法。默认情况下，这些规则是启用的。如果您禁用这些规则，则应考虑启用上述状态消息规则。请勿同时启用这两组规则，否则会导致生成重复警报。无法合并这些事件或警报规则来处理状态消息和组件规则同时处于活动状态的情况。

  • SMS 2003 组件: 发送程序无法通过 LAN (标准安全)连接到远程站点。
  • SMS 2003 组件: 发送程序无法通过 RAS 连接到远程站点。
  • SMS 2003 组件: 发送程序无法通过 LAN (高级安全)连接到远程站点。

为使这些规则起作用，您需要修改它们以指向 SMS 日志文件。同时，每个具有发送程序的 SMS 服务器必须是托管计算机。

默认情况下，BITS 监视是禁用的

因为后台智能传输服务 (BITS) 是应 SMS 高级客户端的要求启动的，所以默认情况下，在 SMS 2003 管理包中将禁用以下规则：

  • SMS 2003 依赖服务运行: 后台智能传输服务

如果您将此服务配置为自动启动，则应启用此规则。

默认情况下，应启用下列规则以监视 BITS 服务的问题，并在 SMS 代理主机无法根据需要启动 BITS 服务时进行报告：

  • SMS 2003 服务故障: 后台智能传输服务异常终止。
  • SMS 2003 服务故障: 后台智能传输服务在启动时挂起。
  • SMS 2003 服务故障: 后台智能传输服务无法启动。
  • SMS 2003 服务故障: 后台智能传输服务无法登录。

SMS 2003 服务故障: 后台智能传输服务依赖于另一服务，但该服务无法启动或不存在。

应用程序提供程序的路径默认设为 C:\SMS\Logs，此路径对某些 SMS 站点服务器可能无效

以下四个组件规则使用应用程序日志提供程序来监视 C:\SMS\Logs 中的 SMS 日志文件：

  • SMS 2003 组件: 发送程序无法通过 LAN (标准安全)连接到远程站点。
  • SMS 2003 组件: 发送程序无法通过 RAS 连接到远程站点。
  • SMS 2003 组件: 发送程序无法通过 LAN (高级安全)连接到远程站点。
  • SMS 2003 组件: 分发管理器无法处理数据包。

发送程序规则默认情况下是启用的，而分发管理器规则默认情况下是禁用的。如果 SMS 安装在驱动器 C 之外的驱动器上或修改了存储日志的默认文件夹，则需要在启用此规则之前对其进行修改。如果不修改此规则即搜索相应文件夹中的日志文件，则警报不会返回您所需的信息。

在修改规则以指定正确的路径时，可以键入日志文件的路径，也可以创建环境变量，并将规则修改为使用此环境变量。如果键入路径，则该路径必须适用于受此规则影响的所有站点服务器。如果存在两个不同路径，分别用于主站点服务器和辅助站点服务器，则可以执行以下操作：

将组件规则 xml 修改为使用日志文件的备用路径。

  1. 在 Operations Manager 2007 操作控制台中，单击“创作”按钮，展开“管理包对象”，然后单击“规则”。

  2. 在“详细信息”窗格中，右键单击要修改的规则，然后选择“属性”。

  3. 单击“配置”选项卡。

  4. 在“响应”窗格中，选择要编辑其 xml 的响应。

  5. 单击“编辑...”按钮。随后将打开“GenerateAlert - Properties”对话框。

  6. 在“GenerateAlert - Properties”对话框的“配置”选项卡上，单击“编辑...”按钮。

  7. 根据需要编辑目录字符串。依次单击“确定”、“应用”，然后单击“确定”保存更改。

另请参阅

概念

支持的 SMS 配置

其他资源

SMS 2003 管理包疑难解答
System Management Server 2003 管理包概述
Microsoft System Management Server 2003 管理包参考


Microsoft System Management Server 2003 管理包参考

以下参考资料提供了 Operations Manager 2007 和 System Management Server 2003 的相关指南。

本节内容

Microsoft System Management Server 2003 管理包的其他资源

SMS 2003 管理包的站点和组件

SMS 2003 计算机组

SMS 2003 规则组

SMS 2003 的提供程序

SMS 2003 脚本

Microsoft SMS 2003 视图

SMS 2003 图表

SMS 2003 报告

另请参阅

概念

管理包监视方案
部署 SMS 2003 管理包

其他资源

System Management Server 2003 管理包概述
执行 SMS 2003 管理包的操作任务
SMS 2003 管理包疑难解答


Microsoft System Management Server 2003 管理包的其他资源

有下列关于 Microsoft System Management Server 2003 管理包的资源可供使用。

Microsoft Operations Manager 2007

要访问 Internet 上的 Operations Manager 2007 核心产品文档以及有关 System Center Operations Manager 2007 的最新信息，请参阅 Operations Manager 2007 产品网页（网址为：http://go.microsoft.com/fwlink/?LinkID=83259，该网页可能为英文）。

SMS 2003

核心产品文档、SMS 管理员控制台帮助、SMS 术语表以及 SMS 联机库中提供部署和使用 SMS 2003 所需的所有信息。可通过 SMS 管理员控制台访问 SMS 联机库和 SMS 管理员控制台帮助。

SMS 2003 联机库

SMS 联机库提供部署和使用 SMS 所需的所有信息的链接。安装 SMS 2003 后，可以使用两种方式运行 SMS 联机库：

  • 从“开始”菜单中，依次单击“程序”、“Systems Management Server”，然后选择“SMS 联机库”。
  • 右键单击 SMS 管理员控制台树中的“SMS 联机库”，然后单击“运行联机库”。

联机库包括以下内容：

  • “SMS 2003 发行说明”，其中包含有关 SMS 的重要信息。
  • “本版本 SMS 的新增功能”，其中介绍了本版本 SMS 2003 与早期版本的差别。
  • 指向 SMS 产品文档网页的链接。
  • 指向 SMS 2003 设备管理功能包和 SMS 2003 操作系统部署功能包下载页面的链接。

Web 上的 SMS

  • 要查找相关产品的技术文章和信息，请访问 Microsoft Systems Management Server 2003 产品网站。SMS 网站还提供有关如何将 SMS 与其他 Microsoft 产品（如 Microsoft Windows® XP 和 Microsoft Office XP）一起使用的特定信息。
  • 有关可浏览和可下载版本的 SMS 2003 核心产品文档的链接，请参阅 Systems Management Server 2003 产品文档网页（该网页可能为英文）。
  • Microsoft 拥有许多免费的新闻组，您可以在其中张贴问题，并从其他用户和 SMS 产品组成员那里获得免费支持。有关免费新闻组的详细信息，请参阅 Systems Management Server 社区网页（该网页可能为英文）。
  • 有关技术技巧文章、常见问题、Web 广播、新闻组等等，请参阅 Systems Management Server 支持 网页（该网页可能为英文）。
  • 要搜索 Microsoft 知识库和其他技术资源，以便快速、准确地找到解决 SMS 问题的方法，请访问 Microsoft 客户帮助和支持网站。可以使用为特定问题分配的“Qxxxxxx”编号或“xxxxxx”编号查询知识库，以便找到有关该问题的文章。

提供反馈

  • 您可以给我们发送反馈和意见，帮助 SMS 文档组为您提供您最需要的产品信息。请将有关文档的反馈发送至 SMS 文档。

另请参阅

概念

SMS 2003 管理包的站点和组件
SMS 2003 计算机组
SMS 2003 规则组
SMS 2003 的提供程序
SMS 2003 脚本
Microsoft SMS 2003 视图
SMS 2003 图表
SMS 2003 报告


SMS 2003 管理包的站点和组件

SMS 2003 组件包括 SMS 中央站点服务器、SMS 站点数据库和 SMS 管理员控制台。通常，SMS 中央站点服务器、SMS 站点数据库和 SMS 管理员控制台驻留在同一台服务器上，每个站点系统角色驻留在专用服务器上。中央站点服务器与数据库，以及任何站点系统角色，组成了单个 SMS 站点。单个 SMS 站点可能包含多个重复的站点系统角色。例如，一个站点可能包含多个客户端访问点 (CAP)。SMS 2003 站点可以分层。单个 SMS 站点可能不包含某些站点服务器角色，如服务器定位器点。

SMS 2003 管理包用于监视 SMS 服务器组件，而不是用于监视 SMS 客户端计算机上的 SMS 功能。但是，Operations Manager 2007 可用于监视驻留在 SMS 客户端计算机上的其他应用程序。

有关 SMS 2003 组件的详细信息，请参阅 SMS 2003 联机库。有关 SMS 2003 文档的链接，请参阅本指南中的Microsoft System Management Server 2003 管理包的其他资源这一节。

重要的服务器角色和组件包括：

  • 客户端访问点
  • 分发点
  • 管理点
  • 服务器定位器点
  • 报告点
  • 站点服务器
  • 站点数据库
  • 发送程序
  • 高级客户端
  • 旧客户端
  • SMS 提供程序
  • SMS 管理员控制台

客户端访问点

CAP 角色是旧客户端和 SMS 站点服务器之间的联系点。CAP 将所有旧客户端数据传递到站点服务器。旧客户端计算机将联系 CAP，以从 SMS 站点服务器获取管理信息。一个 CAP 只服务于一个 SMS 站点，默认安装在站点服务器上。CAP 还提供以下功能：

  • 在安装客户端和在安装客户端后发生更改时，为旧客户端提供特定的配置说明和文件。
  • 作为旧客户端计算机检查播发的点。
  • 从旧客户端接收数据，并将其转发到 SMS 站点服务器。例如，当客户端完成硬件或软件清单，并创建了清单数据文件后，它会将这些数据发送到 CAP。任何源自客户端的状态消息都会复制到 CAP。

分发点

在安装由 SMS 分发的软件程序时，分发点将存储 SMS 客户端所使用的 SMS 数据包源文件。当 SMS 管理员播发某个程序时，客户端可通过旧客户端的 CAP 或高级客户端的管理点获取播发信息和程序信息。

在设置 SMS 时，将为站点服务器自动分配分发点角色。SMS 管理员可以启用分发点，以便使用后台智能传输服务 (BITS)，这样可以将增量数据包文件下载到高级客户端。

高级客户端使用 BITS 来自动检测客户端网络的连接能力，并有效地调整传输速率。只有运行 Microsoft Windows 2000、Microsoft Windows XP Professional 和 Microsoft Windows Server™ 2003 操作系统的客户端才支持此功能。

管理点

管理点是高级客户端和 SMS 站点服务器之间的主要联系点。一个 SMS 站点默认只有一个管理点，尽管可以通过 Windows 网络负载平衡服务来配置多个管理点。与 CAP 和旧客户端之间的关系相似，管理点可提供以下功能：

  • 在安装客户端后为高级客户端提供特定的客户端配置详细信息（也称为高级客户端策略）。
  • 作为高级客户端计算机检查播发的点。
  • 为高级客户端定位分发点。
  • 从高级客户端接收清单、软件计数和状态信息，并将其转发到 SMS 站点服务器。

服务器定位器点

服务器定位器点为旧客户端定位 CAP，为高级客户端定位管理点。服务器定位器点大多用于客户端安装过程中。服务器定位器点可提供以下功能：

  • 为高级客户端定位管理点（如果配置了高级客户端来自动分配 SMS 站点）。
  • 在由登录脚本启动的客户端安装和凭据不足的安装中，为高级客户端提供管理点的位置。
  • 在由登录脚本启动的客户端安装中，为旧客户端分配 SMS 站点，并定位 CAP。

报告点

报告点是运行 Internet Information Services (IIS) 的服务器，该服务器承载报告查看器和任何附加报告的代码。报告点只与其 SMS 站点数据库服务器进行通信。

高级客户端

SMS 2003 借助于高级客户端，满足了移动计算的需要。高级客户端支持 SMS 的完整功能，包括软件分发、资产管理和远程疑难解答。您可以同时管理移动用户和桌面用户，而无需对他们进行区分。高级客户端使用称为 BITS 的 Windows 技术，为所有管理操作提供连接。

旧客户端

如果贵公司需要对不满足支持高级客户端要求的计算机进行管理，可以使用旧客户端。可以启用、配置和控制以下旧客户端安装方法：

  • 由登录脚本启动的客户端安装
  • 客户端推送安装
  • 客户端手动安装

SMS 提供程序

SMS 提供程序负责处理从 SMS 站点数据库获取数据的请求。SMS 提供程序角色与 SMS 站点服务器或 SMS 站点数据库安装在同一台计算机上。建议将 SMS 提供程序和 SMS 站点数据库都安装在站点服务器上。SMS 提供程序可为安装在站点上的 SMS 管理员控制台提供数据访问。

SMS 管理员控制台

SMS 管理员控制台是用于管理 SMS 的图形用户界面。该界面使用随 SMS 产品软件提供的 Microsoft 管理控制台 (MMC) 管理单元。在安装主站点服务器时，将默认安装 SMS 管理员控制台。也可以将其安装在其他服务器或工作站上。

另请参阅

概念

Microsoft System Management Server 2003 管理包的其他资源
SMS 2003 管理包的站点和组件
SMS 2003 计算机组
SMS 2003 规则组
SMS 2003 的提供程序
SMS 2003 脚本
Microsoft SMS 2003 视图
SMS 2003 图表
SMS 2003 报告


SMS 2003 计算机组

The SMS 2003 管理包提供下列计算机组：

  • Microsoft SMS 2003 管理员控制台
  • Microsoft SMS 2003 高级客户端
  • Microsoft SMS 2003 中央站点服务器
  • Microsoft SMS 2003 客户端
  • Microsoft SMS 2003 客户端访问点服务器
  • 基于 IIS 的 Microsoft SMS 2003 组件服务器
  • 基于 SMS 主管服务的 Microsoft SMS 2003 组件服务器
  • Microsoft SMS 2003 分发点服务器
  • Microsoft SMS 2003 管理点服务器
  • Microsoft SMS 2003 主站点服务器
  • Microsoft SMS 2003 提供程序
  • Microsoft SMS 2003 报告点服务器
  • Microsoft SMS 2003 辅助站点服务器
  • Microsoft SMS 2003 发送程序服务器
  • Microsoft SMS 2003 服务器定位器点服务器
  • Microsoft SMS 2003 服务器
  • Microsoft SMS 2003 站点服务器
  • Microsoft SMS 2003 旧客户端

另请参阅

概念

Microsoft System Management Server 2003 管理包的其他资源
SMS 2003 管理包的站点和组件
SMS 2003 计算机组
SMS 2003 规则组
SMS 2003 的提供程序
SMS 2003 脚本
Microsoft SMS 2003 视图
SMS 2003 图表
SMS 2003 报告


SMS 2003 规则组

本节列出 Systems Management Server (SMS) 2003 管理包中生成关键事件和警报的规则组和事件规则。请查看 Operations Manager 2007 操作控制台中的“创作”以检查规则组下的所有规则。

SMS 客户端 - 高级

“SMS 客户端 - 高级”规则组包含与 SMS 高级客户端相关的错误的规则。

  • SMS 2003 服务运行: SMS 代理主机
  • SMS 2003 依赖服务运行: 后台智能传输服务
  • SMS 2003 依赖服务运行: Windows Management Instrumentation

SMS 客户端访问点

“SMS 客户端访问点”规则组包含与 SMS 客户端访问点相关的错误的规则。

  • SMS 2003 服务运行: SMS_EXECUTIVE

SMS 管理点

“SMS 管理点”规则组包含与 SMS 管理点相关的错误的规则。

  • SMS 2003 服务运行: SMS 代理主机
  • SMS 2003 服务运行: SMS_EXECUTIVE
  • SMS 2003 依赖服务运行: World Wide Web 发布服务
  • SMS 2003 依赖服务运行: IIS 管理服务
  • SMS 2003 管理点运行状况: 状态
  • SMS 2003 性能阈值: MP DDR 积压 > 10,000 (3 小时内)
  • SMS 2003 性能阈值: MP HINV 积压 > 10,000 (3 小时内)
  • SMS 2003 性能阈值: MP SINV 积压 > 10,000 (3 小时内)
  • SMS 2003 性能阈值: MP 文件收集积压 > 10,000 (3 小时内)
  • SMS 2003 性能阈值: MP 中继管理器积压 > 10,000 (3 小时内)
  • SMS 2003 性能阈值: MP 状态积压 > 10,000 (3 小时内)
  • SMS 2003 性能阈值: 进程 - 处理器时间百分比(ccmexec) > 95 (3 小时内)

SMS 提供程序

“SMS 提供程序”规则组包含与 SMS 2003 的 SMS 提供程序组件相关的错误的规则。

  • SMS 2003 依赖服务运行: Windows Management Instrumentation

SMS 报告点

“SMS 报告点”规则组包含与 SMS 报告点相关的错误的规则。

  • SMS 2003 服务运行: SMS_REPORTING_POINT
  • SMS 2003 依赖服务运行: World Wide Web 发布服务
  • SMS 2003 依赖服务运行: IIS 管理服务

SMS 发送程序服务器

“SMS 发送程序服务器”规则组包含与 SMS 发送程序服务器相关的错误的规则。

  • SMS 2003 服务运行: SMS_EXECUTIVE

SMS 服务器定位器点

“SMS 服务器定位器点”规则组包含与 SMS 服务器定位器点相关的错误的规则。

  • SMS 2003 依赖服务运行: World Wide Web 发布服务
  • SMS 2003 依赖服务运行: IIS 管理服务
  • SMS 2003 服务运行: SMS_SERVER_LOCATOR_POINT

SMS 服务器 - 公用

“SMS 服务器 - 公用”规则组包含与所有 SMS 服务器相关的错误的规则。

  • SMS 2003 性能阈值: 分页文件 - 使用百分比 > 98 (3 小时内)
  • SMS 2003 性能阈值: 处理器 - 处理器时间百分比(_总计) > 95 (3 小时内)

基于 SMS 主管服务的 SMS 服务器

“基于 SMS 主管服务的 SMS 服务器”规则组包含在运行 SMS 主管服务的任何站点服务器上生成的错误的规则。

  • SMS 2003 性能阈值: 进程 - 处理器时间百分比(smsexec) > 95 (3 小时内)

SMS 站点数据库服务器

“SMS 站点数据库服务器”规则组包含与 SMS 站点数据库服务器相关的错误的规则。

  • SMS 2003 服务运行: SMS_SQL_MONITOR
  • SMS 2003 依赖服务运行: MSSQLSERVER
  • SMS 2003 性能阈值: SMS SQL 连接数 > 500 (2 小时内)

SMS 站点服务器 - 公用

“SMS 站点服务器 - 公用”规则组包含与所有 SMS 站点服务器相关的错误的规则。

  • SMS 2003 服务运行: SMS_SITE_COMPONENT_MANAGER
  • SMS 2003 服务运行: SMS_EXECUTIVE
  • SMS 2003 性能阈值: 站点服务器计划程序作业积压 > 10,000 (3 小时内)
  • SMS 2003 性能阈值: 站点服务器计划程序发送请求积压 > 10,000 (3 小时内)
  • SMS 2003 性能阈值: 站点服务器 SWM 积压 > 10,000 (3 小时内)
  • SMS 2003 性能阈值: 站点服务器 SINV 积压 > 10,000 (3 小时内)
  • SMS 2003 性能阈值: 站点服务器 HINV 积压 > 10,000 (3 小时内)
  • SMS 2003 性能阈值: 站点服务器 DDR 积压 > 10,000 (3 小时内)

SMS 站点数据库服务器 - 主要

“SMS 站点服务器 - 主要”规则组包含与所有 SMS 主站点服务器相关的错误的规则。

  • SMS 2003 性能阈值: 站点服务器 SINV 积压 > 10,000 (3 小时内)
  • SMS 2003 性能阈值: 站点服务器 HINV 积压 > 10,000 (3 小时内)

另请参阅

概念

Microsoft System Management Server 2003 管理包的其他资源
SMS 2003 管理包的站点和组件
SMS 2003 计算机组
SMS 2003 规则组
SMS 2003 的提供程序
SMS 2003 脚本
Microsoft SMS 2003 视图
SMS 2003 图表
SMS 2003 报告


SMS 2003 的提供程序

SMS 2003 管理包所使用的数据提供程序类型如下所示：

  • 应用程序日志
  • 定时事件
  • Windows NT 性能计数器

另请参阅

概念

Microsoft System Management Server 2003 管理包的其他资源
SMS 2003 管理包的站点和组件
SMS 2003 计算机组
SMS 2003 规则组
SMS 2003 脚本
Microsoft SMS 2003 视图
SMS 2003 图表
SMS 2003 报告


SMS 2003 脚本

SMS 2003 管理包中包含在代理上自动运行的 Operations Manager 2007 脚本以及需要由管理员运行的脚本。本节以下部分将介绍其中某些脚本的详细信息。

下列脚本由 Operations Manager 2007 代理自动运行：

  • SMS 2003 Monitor SMS Status Messages
  • SMS 2003 Monitor Site System Summarizer
  • SMS 2003 Service Discovery – Client
  • SMS 2003 Service Discovery – Server
  • SMS 2003 Site Backup Event Suppression
  • SMS 2003 Monitor Management Point Health
  • SMS 2003: Monitor Management Point Availability
  • SMS 2003 Site Hierarchy Discovery
  • SMS 2003 Monitor SMS Inbox
  • SMS 2003 Monitor SMS Executive Crash Dumps

SMS 2003 Monitor SMS Status Messages

SMS 中的许多问题都是通过 SMS 状态系统在内部检测和报告的。状态消息由与 SMS 管理员关注的条件相关的 SMS 组件引发。

状态消息流入 SMS 站点的数据库，并沿站点层次结构向上流入父站点的数据库。只需查询指定站点的数据库中的 SMS 状态消息表，即可监视各个站点的 SMS 状态系统。

已经选择了一组能向 SMS 管理员反映最关键事件的状态消息进行监视。当在数据库中找到其中某个消息时，将生成警报。

此脚本执行以下任务：

  • 检查它是否在无代理托管模式下运行。如果是在无代理托管模式下运行，脚本将退出，不执行任何进一步的操作。
  • 初始化全局变量。
  • 打开 SMS 2003 Monitor SMS Status Messages.VarSet 文件，并从中读取被监视的每个 SMS 站点数据库中已处理的最后一条状态消息的 RecordID。
  • 处理在本地计算机上的每个 SMS 站点数据库中找到的状态消息。
  • 对于每个被监视的 SMS 站点数据库，将已处理的最后一条状态消息的 RecordID 写入 SMS 2003 Monitor SMS Status Messages.VarSet 文件，并关闭此文件。

SMS 2003 Monitor SMS Status Messages 脚本将引发事件，并将事件 ID 设置为所报告的 SMS 状态消息的 ID。表 S.1 描述了所引发的事件的格式。

表 S.1 由 SMS 2003 Monitor SMS Status Messages 脚本引发的事件的格式

参数 | 描述
EventType | 可为“Success”、“Error”、“Warning”或“Information”，具体取决于 SMS 状态消息的严重性
EventNumber | SMS 状态消息 ID
Category | SMS 站点代码
LoggingDomain | 计算机的资源域
LoggingComputer | 计算机的 NetBIOS 名称
Parameter1 | 计算机的 NetBIOS 名称
Parameter2 | SMS 模块名称，例如 SMS 服务器
Parameter3 | SMS 组件名称
Parameter4 | SMS 消息 ID
Parameter5 | Win32 错误代码
Parameter6 | 父级或顶级站点代码
Parameter7 | SMS 状态消息表中状态消息的 RecordID
描述 | “A new monitored SMS status message on machine <NetBIOS Name> from component <Component Name> with message ID <Message ID> was found in the site <Site Code> database.”

SMS 2003 Monitor SMS Status Messages 脚本还通过 ID 号为 1102 的状态消息来报告脚本错误：

EventType= Warning

EventNumber= 1102

Description = The script SMS 2003 Monitor SMS Status Messages running under processing rule <ScriptProcessingRuleName> encountered a runtime error.The error message will contain the text “Failed to <ErrorDescription>.”

所有 SMS 2003 状态消息监视事件规则都以短语“SMS 2003 状态:”开头并位于“SMS 站点数据库服务器”规则组中。

  • SMS 2003 状态: 消息监视

“SMS 2003 状态: 消息监视”使用 SMS 2003“每 30 分钟计划一次，在 00:02 同步”定时事件提供程序来启动脚本。此规则的“知识”属性页上提供了摘要信息。

  • SMS 2003 状态: 脚本错误

“SMS 2003 状态: 脚本错误”监视可能发生的任何脚本错误事件并在事件发生时发出警报。只有编号为 1102 的脚本错误事件才会报告所有脚本错误。此规则的“知识”属性页上提供了解决警报的相关信息。

  • SMS 2003 状态: <status message name>

“SMS 2003 状态: <status message name>”监视特定状态消息事件并在事件发生时发出警报。此规则的“知识”属性页上提供了解决警报的相关信息。

所有警报都带有以下格式的事件描述，其中 $Description$ 是事件描述：

$Logging Computer$ - "Rule Name".$Description$

SMS 2003 Monitor SMS Status Messages.VarSet 文件用于保留所处理的最后一条状态消息的 RecordID（基于每个站点数据库）。VarSet 文件位于 Windows\Temp 目录下。它是一个 Tab 分隔的文件，格式如下：

复制代码
LastRecordID_DBNameRecordID#

例如，RecordID 为 477860 的 LastRecordID_SMS_FLA 表示名为 SMS_FLA 的站点数据库中处理的最后一条状态消息的 RecordID 为 477860。

从以前的版本升级管理包时，SMS 2003 Monitor SMS Status Messages.VarSet 文件中会包括以下内容：

复制代码
LastRecordID476743
LastRecordID_SMS_FLA477860

第一行不包含数据库名称，它指示以前的状态消息监视版本，该版本不支持监视多个数据库。第二行则包含数据库名称 SMS_FLA，表示当前版本的状态消息监视功能支持监视多个数据库。

不会利用第一行数据执行任何操作，因为在有多个站点数据库的情况下，难以确定该数据对应的是哪一个数据库。VarSet 文件中没有删除第一行数据，这是因为可以利用它来评估新的更改，并确保在升级后状态消息监视从正确的 RecordID 开始。

SMS 2003 Monitor Site System Summarizer

站点系统摘要生成器

站点系统状态摘要生成器是 SMS 主管服务的一个线程，它保留所有已定义 SMS 站点系统的状态。默认情况下，它每小时正点轮询一次，以检查当前状态。此轮询间隔是在 SMS 站点控制文件中定义的。建议不要更改轮询间隔。状态信息保存在 SMS 站点数据库的某个表中。

站点系统 DownSince 状态

当站点系统状态摘要生成器在一个轮询间隔时间内无法联系某一站点系统时，即假定该站点系统停机。可能有下列原因导致这一情况：

  • 站点系统未开机、未连接到网络或者不能正常运行。
  • 因为没有连接可用，SMS 站点系统状态摘要生成器未能进行连接。
  • SMS 站点系统状态摘要生成器没有足够的访问权限连接到站点系统。
  • 出现网络问题，使 SMS 站点系统状态摘要生成器无法连接到站点系统。
  • 站点系统已被永久停用。

基于站点系统状态摘要生成器的可用性

SMS 2003 Server Availability 脚本和 SMS 2003 服务器可用性报告利用站点系统状态摘要生成器的状态来报告可用性。SMS 服务器可用性测量利用 DownSince 注册表值来确定服务器是否可用。

基于站点系统状态摘要生成器的可用性的限制

本节说明 SMS 2003 Server Availability 脚本和 SMS 2003 服务器可用性报告利用站点系统状态摘要生成器状态来报告可用性的限制。SMS 服务器可用性测量利用“DownSince”状态来确定服务器是否可用。

基于站点系统状态摘要生成器的可用性监视存在以下限制：

  • 站点系统摘要生成器轮询间隔为一小时。此间隔为站点系统状态摘要生成器轮询所有站点系统留下了充分的时间。出于性能方面的考虑，不能更改此间隔。摘要生成器的超时间隔由站点控制文件中的“Startup Schedule”属性控制，而不由“Wakeup Interval”属性控制。这意味着更改“Wakeup Interval”属性的默认值 60 是无效的。此外，更改“Startup Schedule”也无效。默认情况下，该属性设置为每 15 分钟。站点系统状态摘要生成器每小时正点轮询一次站点系统，无论“Startup Schedule”的设置如何都是如此。
  • 仅当两小时内连续发生两次“SMS 2003 站点系统摘要生成器: 站点系统可能停机”事件时，可用性方法才将该站点视为不可用。这样设计是为了考虑网络临时中断因素。这意味着即使站点只有一小段时间不可用，其可用性仍将被评估为服务中断两小时。
  • 在 SMS 不可用的原因中，有许多是站点系统状态摘要生成器监视不到的。例如，如果 SMS 服务未运行或 SMS 站点数据库不可用（如当 SQL Server 服务停止时），则站点系统状态摘要生成器不会认为 SMS 不可用。
  • 对于承载多个 SMS 服务器角色的计算机而言，可用性数据是密集的。停机时间的计算是基于为停机的站点系统生成的警报数。一次警报具有两个小时的停机时间权重。站点系统状态摘要生成器将计算机上承载的每个站点对象和站点系统角色的当前“DownSince”状态写入数据库的“站点系统状态摘要生成器”表中。

站点系统状态摘要生成器监视脚本检查“站点系统状态摘要生成器”表中的每个站点系统角色。如果某个站点系统被标记为停机，该脚本将引发事件。随后将根据该事件生成警报。多个角色可能会生成多个警报，这将造成停机时间延长。这可能反映为可用性百分比负值，具体取决于相关的时间间隔。

默认情况下，除 SMS 分发点外，每个 SMS 服务器角色将建立两个 SMS 服务器角色，一个用于特定角色，另一个用于 SMS 组件服务器。例如，在站点系统同时承载一个服务器定位器点和一个报告点的情况下，如果服务器脱机时间超过两个小时（两个站点系统状态摘要生成器轮询间隔），站点系统状态摘要生成器会将这两个角色及其 SMS 组件服务器角色标记为停机。

但是，对于这两小时内的每个轮询间隔，只会引发三个警报，一个用于每个服务器角色，一个用于承载这两个服务器角色的物理组件服务器。因为对于这两个小时的时间，将有六个小时被标记为不可用，所以将造成可用性结果为负值。

  • 设置的默认计划为 60 分钟（偏离正点 10 分钟），因此 SMS 2003 Monitor Site System Summarizer 脚本将在站点系统状态摘要生成器轮询间隔（1 小时）开始之后 10 分钟运行。如果摘要生成器完成运行周期所用时间超过 10 分钟，则应适当增加定时事件提供程序的偏差。否则，将错过最新的站点系统状态消息。

SMS 2003: Monitor Management Point Availability

SMS 2003 Monitor Management Point Availability 脚本支持管理点可用性报告。可用性基于管理点的运行状况，并利用在注册表中找到的以下运行状态值：

DWORD 值 HKEY_LOCAL_MACHINE\Microsoft\SMS\MP\MPHealthState

根据可配置计划和报告间隔，此脚本将读取状态为不正常运行（注册表值为 1，而非 0）的时间，并通过 Operations Manager 2007 事件进行报告。

这些可用性数据事件将写入 OperationsManager 数据库和 OperationsManagerDW 数据库。然后，可以运行 Operations Manager 2007 报告，以显示管理点在指定间隔内停机的总时间以及可用性百分比。

MPHealthState 注册表值由 MP 控制管理器维护。它每六分钟更新一次。

此脚本将执行以下操作：

  • 检查它是否在无代理托管模式下运行。如果是在无代理托管模式下运行，脚本将退出，不执行任何进一步的操作。此脚本使用一个本地 VarSet 文件保存变量，因此必须安装 Operations Manager 2007 代理。
  • 初始化全局变量。
  • 获取输入参数 ScheduledInterval 和 ReportingInterval，以分钟为单位。
  • 验证输入参数是否为空、0 或负值。如果输入参数为这些值，将引发脚本错误事件，指示指定的值无效。脚本还将验证 ReportingInterval 值是否小于 ScheduledInterval 值。如果是，将引发脚本错误事件，指示 ReportingInterval 不能小于 ScheduledInterval。这两个值都为 Lng 类型，最大值为 2147483647 (2G -1)。
  • 打开 SMS 2003 Monitor Management Point Availability.VarSet 文件，并将其内容复制到本地集合。如果该文件不存在，不会引发脚本错误事件。如果该文件存在但无法打开，则会引发脚本错误事件。
  • 检查管理点的可用性。
    • 如果当前 SMS 版本低于 2.50.3067.0000，脚本将退出而不引发错误，因为 MPHealthState 注册表值不存在。代理响应日志文件 AgentResponses-Configuration Group Name.log 将包含“Monitoring Management Point health is not supported on this SMS build.”语句。可将 HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OperationsManager 注册表项下的 EnableActiveDebugging DWORD 值设置为 1，从而启用日志记录。
    • 从注册表 DWORD 值 HKEY_LOCAL_MACHINE\Microsoft\SMS\MP\MPHealthState 获取管理点当前运行状态。如果无法获得该值，脚本将退出而不引发错误，因为 MP 控制管理器尚未创建该注册表值。
    • 从 VarSet 集合获取开始日期和时间。如果是第一次运行此脚本，并且处于新的报告周期的开始，则没有相关条目。脚本将初始化 VarSet 集合中的持续时间和开始日期，然后退出而不引发错误。它将持续时间设为 0，并将开始日期设为当前日期和时间。
    • 对于当前报告间隔，如果 MPHealthState 注册表值设为 1，脚本将根据指定的计划间隔累计 VarSet 集合中的不可用持续时间。
    • 如果报告间隔过期且管理点一直不可用，则通过创建可用性数据事件进行报告。对于下一个报告期间，脚本将 VarSet 集合中的持续时间重置为 0，并将开始日期重置为当前本地时间。
    • 如果在检查管理点可用性时发生错误，将引发脚本错误。

Event Number = 1102

Event Type = Warning

Message = "The script ‘SMS 2003 Monitor Management Availability' running under processing rule <ProcessingRuleName> encountered a runtime error."CrLf "Failed to check Management Point availability.” <ErrorString>

  • 将 VarSet 集合的内容写入本地 SMS 2003 Monitor Management Point Availability.VarSet 文件，并关闭此文件。如果此文件不存在，则创建此文件。如果未设置 VarSet 变量，则此文件中不包含其相关条目。如果在写入文件时发生错误，脚本将引发脚本错误。

SMS 2003: Monitor SMS Inbox

SMS 的大多数关键的服务器端活动都是通过读取和写入收件箱中的文件来完成的。当 SMS 收件箱过满时，则表明 SMS 在处理方面已落后。这可能有多种原因，包括但不限于文件损坏、进程停止、磁盘空间不足或软件分发活动异常多。这种问题极少出现，但对于拥有很多站点的客户而言，这些问题很严重。

SMS 收件箱有若干性能计数器，可测量由服务组件排入队列的项目数，而不会测量磁盘上等待处理的实际项目数。SMS 服务组件将在处理完当前队列后更新性能计数器。这可能会使性能计数器更新的频率过低，妨碍及时检测到严重的积压情况。新增的“SMS 2003: Monitor SMS Inbox”脚本添加了直接监视功能，方法是对关键 SMS 服务器收件箱中的文件计数；当特定收件箱中的文件数超过用户配置的阈值时，通过 Operations Manager 2007 提醒管理员。

所有规则都位于“SMS 站点服务器 – 公用”处理规则组中，该规则组将这些规则应用于中央站点、主站点和辅助站点。可通过改写来配置传递到此脚本的阈值。

出于性能方面的考虑，这些规则不会应用于管理点或任何其他 SMS 站点系统角色。

计划和可选配置

为尽量减少监视收件箱对性能造成的影响，将同步相关规则以便每天运行一次。这些规则将以 15 分钟的间隔错开，起始于上午 01:00，这样，一次只有一条规则在运行。例如，第一条规则于上午 01:00 对第一个收件箱中的文件进行计数。下一条规则于上午 01:15 对第二个收件箱中的文件进行计数，以此类推，直到完成对所有收件箱的计数。

您可以按照在 Operations Manager 2007 中计划规则脚本执行时通常采取的步骤来修改此计划。激活此功能不需要进行初始配置。以下是您可以执行的可选配置更改：

  • 更改每个收件箱的默认阈值。
  • 更改单个收件箱规则的计划。

可以按照在任何管理包中配置阈值事件规则时通常采取的步骤来更改这些可选配置。

阈值警报和阈值

只要在每次处理监视规则时达到为特定收件箱规则配置的阈值，就会生成一个警报。只要脚本在尝试监视每个收件箱中的文件数时遇到无效阈值或错误，就会生成脚本错误警报。

编辑性能阈值

  1. 在 Operations Manager 2007 管理员控制台中，单击“创作”。

  2. 在“创作”窗格中，依次导航到“创作”、“管理包对象”、“监视器”。

  3. 在“监视器”窗格中，将范围更改为“SMS 服务器”。

  4. 依次导航到“SMS 服务器”、“实体运行状况”、“MOM 2005 计算机角色运行状况”，然后展开要编辑的服务器角色。

    • DB - 数据库服务器
    • MP - 管理点服务器
    • SS - 站点服务器

  5. 双击要编辑的性能阈值监视规则。随后将打开“性能阈值属性”对话框。

  6. 选择“配置”选项卡。

  7. 单击“编辑...”。随后将打开“Xml 配置”对话框。

  8. 在 XML 文本中，编辑要修改的阈值。

    • 指定 <CriticalErrorExpression> 中嵌套的 <ValueExpression>，更改严重错误阈值。
    • 指定 <WarningExpression> 中嵌套的 <ValueExpression>，更改警告阈值。

  9. 单击“确定”。单击“确定”。修改后的阈值将分发到服务器。

每个收件箱监视规则的默认阈值设为 10,000。您应根据自己的特定环境，为“SMS 2003: Monitor SMS Inbox”脚本中的 FileCountThreshold 参数设置相应的阈值。有效的阈值在 1 到 2147483647 (0x7FFFFFFF) 之间（包含这两个值）。无效的阈值为零 (0) 或大于 2147483647 的值，因为在 32 位范围内这些值会产生负数。

有关收件箱文件夹的描述及其在 Systems Management Server 中的使用方法，请参阅 Microsoft 客户帮助和支持中的相关主题。

SMS 2003 Monitor SMS Executive Crash Dumps 脚本

此脚本位于 SMS 管理员控制台中的“Scripts”文件夹中，名为“SMS 2003 Monitor SMS Executive Crash Dumps”。此脚本执行下列操作：

  • 确定目标计算机是否在无代理模式下运行。如果是在无代理模式下运行，脚本将退出，不执行进一步的操作。此脚本使用一个本地 VarSet 文件保存变量，因此必须在所有目标计算机上安装 Operations Manager 2007 代理。
  • 打开本地 SMS 2003 Monitor SMS Executive Crash Dumps.VarSet 文件，并将其内容读取到一个集合中。如果该文件不存在，不会引发脚本错误事件。如果该文件存在但无法打开，则会引发脚本错误事件，并显示包含以下文本的消息：

Failed to load script variables.

  • 检查在上次执行检查之后是否发生了新的故障转储。如果发生了新的故障转储，脚本将引发事件，以报告这次新的故障转储。为引发脚本错误事件，脚本将执行以下操作：
    • 从注册表中 SMS Identification 注册表项下的注册表值“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Identification\ Installation Directory”获取 SMS 安装目录。如果无法获得路径，脚本将引发脚本错误事件消息并退出，消息文本如下：

Failed to read registry value.

  • 通过在检索到的 SMS 安装目录之后附加“\Logs\CrashDumps”，构建 CrashDumps 目录的完整路径。
  • 检查 CrashDumps 目录是否存在。如果不存在，脚本将在日志中记录无法确认文件夹存在，并退出，而不执行进一步的操作。代理响应日志文件 AgentResponses-Configuration Group Name.log 将包含以下语句：

Failed to verify existence of crash dump directory: <CrashDumpsPath>.

将 HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OperationsManager 注册表项下的 EnableActiveDebugging DWORD 值设置为 1，从而启用日志记录。

  • 从 VarSet 集合获取上一次故障转储文件夹的创建日期。
  • 检查是否创建了新的故障转储，并且只对最新的故障转储执行操作。为确定哪一个是最新的，将使用所保存的上一次故障转储的文件夹创建日期（如果可用）。日期和时间的比较是基于文件夹的创建日期，精确到秒。
  • 如果发生了新的故障转储，或是第一次运行此脚本，脚本将记录并创建事件 1710，指定新的故障转储文件夹和路径。脚本将故障转储的文件夹创建日期保存到 VarSet 集合中。如果未发生故障转储，也将对此进行记录。
  • 将 VarSet 集合的内容写入本地 SMS 2003 Monitor SMS Executive Crash Dumps.VarSet 文件，并关闭此文件。如果此文件不存在，则创建此文件。如果未设置 VarSet 变量，则此文件中不包含其相关条目。如果在写入文件时发生错误，将引发脚本错误事件消息，消息文本如下：Failed to save script variables.

SMS 2003 Monitor SMS Executive Crash Dumps 事件

SMS 2003 Monitor SMS Executive Crash Dumps 脚本通过事件 1710 报告发生了故障，如下所述：

EventType = Error

EventNumber = 1710

Category = SMS Site Code

Description = SMS Executive in site “XXX” has crashed.有关详细信息，请参阅 <Drive> \SMS\Logs\CrashDumps\NewFolder 下的故障转储信息。

SMS 2003 Monitor SMS Executive Crash Dumps 脚本错误事件

“SMS 2003 Monitor SMS Executive Crash Dumps”脚本通过事件 1102 报告运行时脚本错误。

EventType = Warning

EventNumber = 1102

Description = The script “SMS 2003 Monitor SMS Executive Crash Dumps” running under processing rule SMS 2003 Crash Dumps:Monitoring SMS Executive encountered a runtime error.CrLf “Failed to <Message>." ErrorString

SMS 2003 Server Availability 脚本

SMS 是用于桌面配置管理的关键企业应用程序。客户需要跟踪其服务可用性。管理包提供了一个 Microsoft SQL Server™ 示例脚本。为响应 SMS 站点系统状态摘要生成器标记的停机状态，将引发警报，该示例脚本可根据这些警报来计算 SMS 站点系统的可用性。可确定指定的任意天数内的可用性。此度量可用于支持已建立的服务级别协议 (SLA)。

SMS 2003 Server Availability 脚本的限制

SMS 2003 Server Availability 脚本具有以下限制。

所显示的数据仅限于 Operations Manager 2007 数据库整理间隔。默认情况下，此脚本只返回最近 7 天的数据以及最近 30 天的数据。但是，OperationsManager 数据库的整理间隔为 4 天，因此以 7 天或 30 天的间隔执行此脚本将返回相同的结果。如果需要得到反映较长时间段的报告，则需要增加整理间隔或使用 SMS 2003 服务器可用性报告，该报告是针对存储长期操作数据的 OperationsManagerDW 数据库执行的。对于较短的时间段，需要更改脚本中 7 天和 30 天的间隔。

脚本算法

站点系统摘要生成器将每小时尝试一次联系每个站点系统。如果无法联系某个站点系统，它会在“站点系统状态摘要生成器”表中将该计算机列为停机。为减少符合此条件的误报数，管理包将合并事件，并且仅在两小时内发生两个事件的情况下才引发警报。当您运行存储过程时，它将计算在指定天数内引发的“站点系统可能停机”警报数，再从总的可用时间减去停机时间，并返回在这期间的可用性百分比。如果某台计算机在指定间隔内未记录任何“站点系统可能停机”警报，则计算出的该计算机的可用性为 100%。

除非希望查看每日趋势，否则脚本的运行频率无需高于七天。

默认情况下，此脚本只返回最近 7 天的数据以及最近 30 天的数据。通过指定较长的数据间隔，可以更准确地估算服务器运行时间。设置的间隔不要长于 Operations Manager 2007 数据库整理周期。

以下示例说明，如果取较长时间段内的数据平均值，则服务器可用性会上升：

  • 如果在两个小时内生成了两个事件，将生成一个警报。如果在最近 7 天内生成了一个警报，计算过程将如下所示：
    • 7 天内总小时数 = 7 * 24 = 168
    • 停机总小时数 = 2 * 2 = 4
    • 运行总小时数 = (168 - 2) = 166
    • 可用性百分比 = (166 / 168) * 100 = 98.809%
  • 如果在最近 30 天内生成一个警报，计算过程将如下所示：
    • 30 天内总小时数 = 30 * 24 = 720
    • 停机总小时数 = 2 * 2 = 4
    • 运行总小时数 = (720 - 2) = 718
    • 可用性百分比 = (718 / 720) * 100 = 99.72%
  • 如果在最近 84 天内生成一个警报，计算过程将如下所示：
    • 84 天内总小时数 = 84 * 24 = 2016
    • 停机总小时数 = 2 * 2 = 4
    • 运行总小时数 = (2016 - 2) = 2014
    • 可用性百分比 = (2014 / 2016) * 100 = 99.9%

以下示例说明，随着在相同的时间段内记录更多的警报，服务器可用性会随之变化：

  • 如果在最近 30 天内生成两个警报，计算过程将如下所示：
    • 30 天内总小时数 = 30 * 24 = 720
    • 停机总小时数 = 2 * 2 = 4
    • 运行总小时数 = (720 - 4) = 716
    • 可用性百分比 = (716 / 720) * 100 = 99.44%
  • 如果在最近 30 天内生成三个警报，计算过程将如下所示：
    • 30 天内总小时数 = 30 * 24 = 720
    • 停机总小时数 = 3 * 2 = 6
    • 运行总小时数 = (720 - 6) = 714
    • 可用性百分比 = (714 / 720) * 100 = 99.16%

站点系统状态摘要生成器的轮询间隔固定为一小时，且无法通过 SMS 管理员控制台进行更改。修改此间隔不会提高此脚本的准确性。可以更改事件合并间隔，但建议您不要这样做，因为这并不能提高结果的准确性。实际上，减小合并间隔会使结果更加不可靠，因为两小时的合并间隔减少了由于网络瞬时中断所造成的虚假结果。

另请参阅

概念

Microsoft System Management Server 2003 管理包的其他资源
SMS 2003 管理包的站点和组件
SMS 2003 计算机组
SMS 2003 规则组
SMS 2003 的提供程序
SMS 2003 脚本
Microsoft SMS 2003 视图
SMS 2003 图表
SMS 2003 报告


Microsoft SMS 2003 视图

SMS 2003 管理包提供以下通用视图：

  • 警报
  • 事件
  • SMS 2003 站点层次结构图表
  • 状态视图
  • 任务状态视图
  • 常规
  • 性能

还提供了专为 SMS 2003 定制的下列视图：

SMS 2003 站点层次结构图表

  • SMS 2003 层次结构

常规

  • 最近 72 小时内来自 SMS 中央站点服务器的警报
  • 最近 72 小时内的新警报

性能视图

可以逐一配置视图，以显示特定计算机的数据。如要执行该操作，建议您将要自定义的视图复制到“我的工作区”中，重命名该视图，然后按您的要求进行自定义。可以通过单独选择所需计算机的计数器来简化图表。

积压\管理点服务器

  • 最近 48 小时内的 DDR 积压
  • 最近 48 小时内的文件收集积压
  • 最近 48 小时内的硬件清单积压
  • 最近 48 小时内的中继积压
  • 最近 48 小时内的软件清单积压
  • 最近 48 小时内的状态积压

积压\站点服务器

  • 最近 48 小时内的 DDR 积压
  • 最近 48 小时内的硬件清单积压
  • 最近 48 小时内的计划程序作业积压
  • 最近 48 小时内的计划程序发送请求积压
  • 最近 48 小时内的软件清单积压
  • 最近 48 小时内的 SWM 积压

常规\管理点服务器

  • 最近 48 小时内的逻辑磁盘使用情况
  • 最近 48 小时内的内存使用情况
  • 最近 48 小时内的处理器使用情况

常规\站点服务器

  • 最近 48 小时内的逻辑磁盘使用情况
  • 最近 48 小时内的内存使用情况
  • 最近 48 小时内的处理器使用情况
注意
“最近 48 小时内的逻辑磁盘使用情况”视图的性能提供程序随 Microsoft Windows Server 基础操作系统管理包安装。

处理速率

  • *最近 24 小时内 SMS 2003 管理点服务器上的所有消息处理速率
  • *最近 24 小时内 SMS 2003 管理点服务器上的所有报告处理速率
  • *最近 24 小时内 SMS 2003 站点服务器上的所有报告处理速率

处理速率\管理点服务器

  • 最近 24 小时内每秒 DDR 数
  • 最近 24 小时每秒 DM 数据库连接尝试次数
  • 最近 24 小时内每秒 DM DDR 数
  • 最近 24 小时内每秒 DM 发现转换请求数
  • 最近 24 小时内每秒 DM DP 位置数
  • 最近 24 小时内每秒 DM 硬件清单转换请求数
  • 最近 24 小时内每秒 DM HINV 数
  • 最近 24 小时内每秒 DM ISAPI 请求数
  • 最近 24 小时内每秒 DM 计算机设置请求数
  • 最近 24 小时内每秒 DM 数据包版本请求数
  • 最近 24 小时内每秒 DM SINV 数
  • 最近 24 小时内每秒 DM 软件策略正文请求数
  • 最近 24 小时内每秒 DM 软件策略 ID 请求数
  • 最近 24 小时内每秒 DM 状态数
  • 最近 24 小时内每秒 DM 设置请求总数
  • 最近 24 小时内每秒 DP 位置数
  • 最近 24 小时内每秒获取验证请求数
  • 最近 24 小时内每秒获取策略请求数
  • 最近 24 小时内每秒 HINV 数
  • 最近 24 小时内每秒 ISAPI 请求数
  • 最近 24 小时内每秒 MP 位置数
  • 最近 24 小时内每秒 PA 请求数
  • 最近 24 小时内每秒中继报告数
  • 最近 24 小时内每秒 SINV 数
  • 最近 24 小时内每秒执行的 SP 数
  • 最近 24 小时内每秒状态数
  • 最近 24 小时内的 DDR 总数
  • 最近 24 小时内的 DM DDR 总数
  • 最近 24 小时内的 DM HINV 总数
  • 最近 24 小时内分发的 DM ISAPI 请求总数
  • 最近 24 小时内收到的 DM ISAPI 请求总数
  • 最近 24 小时内的 DM SINV 总数
  • 最近 24 小时内的 DM 状态总数
  • 最近 24 小时内的 HINV 总数
  • 最近 24 小时内的中继报告总数
  • 最近 24 小时内的 SINV 总数
  • 最近 24 小时内的状态总数

处理速率\站点数据库服务器

  • 最近 24 小时内 SQL Server 用户连接数

处理速率\站点服务器

  • 最近 24 小时内每分钟 DDR 数
  • 最近 24 小时内每分钟 HINV 数
  • 最近 24 小时内每分钟 SINV 数
  • 最近 24 小时内每分钟状态数
  • 最近 24 小时内每分钟 SWM 数
  • 最近 24 小时内的 DDR 总数
  • 最近 24 小时内的 HINV 总数
  • 最近 24 小时内的 SINV 总数
  • 最近 24 小时内的状态总数
  • 最近 24 小时内的 SWM 总数

另请参阅

概念

Microsoft System Management Server 2003 管理包的其他资源
SMS 2003 管理包的站点和组件
SMS 2003 计算机组
SMS 2003 规则组
SMS 2003 的提供程序
SMS 2003 脚本
Microsoft SMS 2003 视图
SMS 2003 图表
SMS 2003 报告


SMS 2003 图表

SMS 2003 管理包提供了其 SMS 层次结构的拓扑图。其中显示了站点服务器和站点系统及其相互关系，并带有上下文相关的信息。拓扑图包括逻辑数据（例如层次结构和站点）和物理数据（例如站点服务器和站点系统）。由于 SMS 2003 的层次结构可能很大，您可以使用“组”筛选器将层次结构视图的范围缩小到任何 SMS 2003 计算机组。

在 Operations Manager 2007 中对 SMS 2003 管理包的拓扑图的支持有以下要求：

  • 在要用图表形式表示的 SMS 服务器上安装 SMS 2003 SP3
  • 必须启用拓扑图
  • 必须使用 SMS 2003 管理员控制台为每个站点角色配置完全限定的域名 (FQDN)

为使拓扑发现能生成 SMS 2003 层次结构的图表，必须管理 SMS 提供程序计算机，并且必须在这些计算机上安装代理，并为其他计算机启用代理。同时，为显示站点服务器和站点系统之间的连接，必须已由 SMS 发现进程发现站点系统，并且这些站点系统必须是“所有系统”集合的成员。

从主站点以基于每站点的方式执行发现，并且发现的辅助站点是作为父级主发现的一部分。将通过工具提示和服务器注释的形式提供发现的数据。此外，还可将图表导出为 Microsoft Visio® 文件格式。

SMS 服务器拓扑图注释

服务器类型图标

  • 数据库服务器类型：站点数据库
  • 站点系统类型：管理点
  • 服务器类型：中央站点、主站点、辅助站点和站点系统

连接线

连接线的颜色和样式指示两台计算机的关系类型：

  • 站点服务器之间的连接线为黑色实线。
  • 站点服务器与站点系统之间的连接线为蓝色虚线。

另请参阅

概念

Microsoft System Management Server 2003 管理包的其他资源
SMS 2003 管理包的站点和组件
SMS 2003 计算机组
SMS 2003 规则组
SMS 2003 的提供程序
SMS 2003 脚本
Microsoft SMS 2003 视图
SMS 2003 图表
SMS 2003 报告


SMS 2003 报告

SMS 2003 管理包中提供本节所介绍的各种报告。报告是可选组件，必须单独安装。有关部署报告服务器的详细信息，请参阅有关 Operations Manager 2007 产品的网页（网址为：http://go.microsoft.com/fwlink/?LinkID=83259，该网页可能为英文）。

SMS 报告

Systems Management Server 2003 管理包包括以下三种类型的报告：

  • 性能
  • 配置
  • 可用性

报告针对通过对象选取器选择的组或对象。所有报告均为利用 Operations Manager 2007 报告功能的链接报告。报告有七种导出格式可供选择。

可用性报告

在 SMS 2003 管理包中有三种“可用性”报告。可通过选择 SMS 服务器组（“Microsoft.SMS.2003.ServersGroup”）来对“Microsoft.SMS.2003.ServersGroup”对象选取器目标组执行这些报告。

服务器可用性报告

服务器可用性报告基于特定服务器上所有实体的聚合运行状况。此报告将包括 SMS 监视器角色的运行状况以及任何其他被监视角色的运行状况。

站点服务器可用性

站点服务器可用性报告基于站点服务器的运行状况。此报告使用运行状况监视器中的信息。

管理点可用性报告

管理点可用性报告基于管理点的运行状况。此报告使用运行状况监视器中的信息。

配置报告

SMS 2003 管理包提供一种配置报告，即 SMS 2003 服务器客户配置报告。此报告是一个基本的自定义配置报告，其中包含一台或一组 SMS 服务器的属性。

此报告显示下列 SMS 属性：

  • 版本（SMS 产品的版本）
  • 站点系统类型（站点系统类型、服务器类型、数据库服务器类型）
  • 组件（站点服务器、服务器定位器点、分发点、管理点、报告点、数据库服务器、提供程序、发送程序、客户端访问点）
  • 站点代码（SMS 站点代码）
  • 服务器类型（中央、主、辅助站点服务器）
  • 名称（NetBIOS 名称）
  • 数据库服务器类型（站点数据库服务器）

可对“Microsoft.SMS.2003.ServersGroup”对象选取器目标组执行此报告。

性能

性能报告的分组方式如下：首先根据被监视的站点角色分组，然后根据计数器是与速率相关的性能计数器（例如每秒或每分钟）还是原始计数器（总计）来分组。这种分组方式可确保报告的所有计数器都使用相似的计数法。

已根据所需的分析类型而开发了各种报告。根据所需的不同的分析类型，提供了两组报告。一组显示特定 SMS 服务器角色（例如管理点或站点服务器）的所有性能计数器。另一组显示所有站点角色的特定处理对象（例如硬件清单）的所有计数器。

SMS 2003 服务器性能组报告

要运行下列报告，请在对象选取器目标组中选择“Microsoft.SMS.2003.ServerPerformanceGroup”。

SMS 2003 数据发现记录(DDR)原始性能

此报告显示所有适用 SMS 服务器角色的数据发现记录 (DDR) 积压和已处理总计。

SMS 2003 性能测量: 站点服务器 DDR 积压 | 排入队列的 DDR 总数
SMS 2003 性能测量: 已处理的站点服务器 DDR 总数 | 已处理的 DDR 总数
SMS 2003 性能测量: MP DDR 积压 | 排入队列的消息数
SMS 2003 性能测量: MP DDR 管理器(报告总数) | 报告总数
SMS 2003 性能测量: 已处理的 DMP DDR 总数 | 生成的发现报告总数

SMS 2003 数据发现记录(DDR)速率性能

此报告显示所有适用 SMS 服务器角色的数据发现记录 (DDR) 处理速率。

SMS 2003 性能测量: 站点服务器 DDR 处理速率 | 每分钟处理的 DDR 数
SMS 2003 性能测量: MP DDR 管理器(每秒报告总数) | 每秒报告总数
SMS 2003 性能测量: DMP DDR 处理速率 | 每秒生成的发现报告数

SMS 2003 硬件清单(HINV)原始性能

此报告显示所有适用 SMS 服务器角色的硬件清单 (HINV) 积压和已处理总计。

SMS 2003 性能测量: 站点服务器 HINV 积压 | 排入队列的 MIF 总数
SMS 2003 性能测量: 已处理的站点服务器 HINV 总数 | 已处理的 MIF 总数
SMS 2003 性能测量: MP HINV 积压 | 排入队列的消息数
SMS 2003 性能测量: MP HINV 管理器(报告总数) | 报告总数
SMS 2003 性能测量: 已处理的 DMP HINV 总数 | 生成的硬件清单报告总数

SMS 2003 硬件清单(HINV)速率性能

此报告显示所有适用 SMS 服务器角色的硬件清单 (HINV) 处理速率。

SMS 2003 性能测量: 站点服务器 HINV 处理速率 | 每分钟处理的 MIF 数
SMS 2003 性能测量: MP HINV 管理器(每秒报告总数) | 每秒报告总数
SMS 2003 性能测量: MP HINV 重试管理器(每秒报告总数) | 每秒报告总数
SMS 2003 性能测量: DMP HINV 处理速率 | 每秒生成的硬件清单报告数

SMS 2003 软件清单(SINV)原始性能

此报告显示所有适用 SMS 服务器角色的软件清单 (SINV) 积压和已处理总计。

SMS 2003 性能测量: 站点服务器 SINV 积压 | 排入队列的 SINV 总数
SMS 2003 性能测量: 已处理的站点服务器 SINV 总数 | 已处理的 SINV 总数
SMS 2003 性能测量: MP 文件收集积压 | 排入队列的消息数
SMS 2003 性能测量: MP SINV 积压 | 排入队列的消息数
SMS 2003 性能测量: MP Sinv 管理器(报告总数) | 报告总数
SMS 2003 性能测量: 已处理的 DMP SINV 总数 | 生成的软件清单报告总数

SMS 2003 软件清单(SINV)速率性能

此报告显示所有适用 SMS 服务器角色的软件清单 (SINV) 处理速率。

SMS 2003 性能测量: 站点服务器 SINV 处理速率 | 每分钟处理的 SINV 数
SMS 2003 性能测量: MP Sinv 管理器(每秒报告总数) | 每秒报告总数
SMS 2003 性能测量: MP Sinv 集合文件管理器(每秒报告总数) | 每秒报告总数
SMS 2003 性能测量: DMP SINV 处理速率 | 每秒生成的软件清单报告数

SMS 2003 服务器系统资源性能

此报告显示 SMS 服务器角色的系统资源使用情况。

SMS 2003 性能测量: 内存 - 使用中的已提交字节百分比 | 使用中的已提交字节
SMS 2003 性能测量: 分页文件 - 使用百分比 | 使用百分比
SMS 2003 性能测量: 处理器 - 处理器时间百分比(_总计) | 处理器时间百分比
SMS 2003 性能测量: 进程 - 处理器时间百分比(smsexec) | 处理器时间百分比
SMS 2003 性能测量: 进程 - 处理器时间百分比(ccmexec) | 处理器时间百分比
SMS 2003 性能测量: 系统 - 系统运行时间 | 系统运行时间

SMS 2003 软件计数(SWM)原始性能

此报告显示所有适用 SMS 服务器角色的软件计数 (SWM) 积压和已处理总计。

SMS 2003 性能测量: 站点服务器 SWM 积压 | 排入队列的 SWM 用法文件总数
SMS 2003 性能测量: 已处理的站点服务器 SWM 总数 | 已处理的 SWM 用法记录总数
SMS 2003 性能测量: MP 中继管理器积压 | 排入队列的消息数
SMS 2003 性能测量: MP 中继管理器(报告总数) | 报告总数

SMS 2003 软件计数(SWM)速率性能

此报告显示所有适用 SMS 服务器角色的软件计数 (SWM) 处理速率。

SMS 2003 性能测量: 站点服务器 SWM 处理速率 | 每分钟处理的 SWM 用法记录数
SMS 2003 性能测量: MP 中继管理器(每秒报告总数) | 每秒报告总数

SMS 2003 状态消息原始性能

此报告显示所有适用 SMS 服务器角色的 SMS 状态消息积压和已处理总计。

SMS 2003 性能测量: 已处理的站点服务器状态消息总数 | 收到的消息
SMS 2003 性能测量: MP 状态积压 | 排入队列的消息数
SMS 2003 性能测量: MP 状态管理器(事件总数) | 事件总数
SMS 2003 性能测量: 已处理的 DMP 状态消息总数 | 发出的状态消息总数

SMS 2003 状态消息速率性能

此报告显示所有适用 SMS 服务器角色的 SMS 状态消息处理速率。

SMS 2003 性能测量: 站点服务器状态处理速率 | 每秒处理的消息数
SMS 2003 性能测量: MP 状态管理器(每秒事件总数) | 每秒事件总数
SMS 2003 性能测量: DMP 状态处理速率 | 每秒发出的状态消息数

SMS 2003 支持服务器角色性能

此报告显示支持 SMS 服务器角色的服务的性能。

SMS 2003 性能测量: Web 服务(每秒 ISAPI 扩展请求数) | 每秒 ISAPI 扩展请求数
SMS 2003 性能测量: SMS SQL 连接数 | 用户连接数

SMS 2003 管理点服务器报告

要运行下列报告，请在对象选取器目标组中选择“Microsoft Management Point Servers”。

SMS 2003 设备管理点原始性能

此报告显示 SMS 设备管理点服务器角色的已处理总计。

SMS 2003 性能测量: 已处理的 DMP DDR 总数 | 生成的发现报告总数
SMS 2003 性能测量: 已处理的 DMP HINV 总数 | 生成的硬件清单报告总数
SMS 2003 性能测量: 已处理的 DMP SINV 总数 | 生成的软件清单报告总数
SMS 2003 性能测量: 已处理的 DMP 状态消息总数 | 发出的状态消息总数
SMS 2003 性能测量: 已分发的 DMP ISAPI 请求总数 | 已分发的消息总数
SMS 2003 性能测量: 收到的 DMP ISAPI 请求总数 | 收到的消息总数

SMS 2003 设备管理点速率性能

此报告显示 SMS 设备管理点服务器角色的处理速率。

SMS 2003 性能测量: DMP 设置请求速率 | 每秒 DMP 设置请求数
SMS 2003 性能测量: DMP 计算机设置请求速率 | 每秒计算机设置请求数
SMS 2003 性能测量: DMP 软件策略 ID 请求速率 | 每秒软件策略 ID 请求数
SMS 2003 性能测量: DMP 软件策略正文请求速率 | 每秒软件策略正文请求数
SMS 2003 性能测量: DMP 数据包版本请求速率 | 每秒数据包版本请求数
SMS 2003 性能测量: DMP 发现转换请求速率 | 每秒发现转换请求数
SMS 2003 性能测量: DMP 硬件清单转换请求速率 | 每秒硬件清单转换请求数
SMS 2003 性能测量: DMP 数据库连接尝试速率 | 每秒数据库连接尝试次数
SMS 2003 性能测量: DMP DDR 处理速率 | 每秒生成的发现报告数
SMS 2003 性能测量: DMP HINV 处理速率 | 每秒生成的硬件清单报告数
SMS 2003 性能测量: DMP DP 位置请求处理速率 | 每秒处理的位置请求数
SMS 2003 性能测量: DMP ISAPI 消息处理速率 | 每秒分发的消息数
SMS 2003 性能测量: DMP SINV 处理速率 | 每秒生成的软件清单报告数
SMS 2003 性能测量: DMP 状态处理速率 | 每秒发出的状态消息数

SMS 2003 管理点原始性能

此报告显示 SMS 管理点服务器角色的积压和已处理总计。

SMS 2003 性能测量: MP DDR 积压 | 排入队列的消息数
SMS 2003 性能测量: MP DDR 管理器(报告总数) | 报告总数
SMS 2003 性能测量: MP HINV 积压 | 排入队列的消息数
SMS 2003 性能测量: MP HINV 管理器(报告总数) | 报告总数
SMS 2003 性能测量: MP 文件收集积压 | 排入队列的消息数
SMS 2003 性能测量: MP SINV 积压 | 排入队列的消息数
SMS 2003 性能测量: MP SINV 管理器(报告总数) | 报告总数
SMS 2003 性能测量: MP 中继管理器积压 | 排入队列的消息数
SMS 2003 性能测量: MP 中继管理器(报告总数) | 报告总数
SMS 2003 性能测量: MP 状态积压 | 排入队列的消息数
SMS 2003 性能测量: MP 状态管理器(事件总数) | 事件总数

SMS 2003 管理点速率性能

此报告显示 SMS 管理点服务器角色的处理速率。

SMS 2003 性能测量: MP 位置管理器(每秒 MP 请求数) | 每秒 MP 请求数
SMS 2003 性能测量: MP 位置管理器(每秒 DP 请求数) | 每秒 DP 请求数
SMS 2003 性能测量: MP 获取策略(每秒请求数) | 每秒请求数
SMS 2003 性能测量: MP 获取验证(每秒请求数) | 每秒请求数
SMS 2003 性能测量: MP 策略管理器(每秒 PA 请求数) | 每秒 PA 请求数
SMS 2003 性能测量: MP DAL (每秒执行的 SP 数) | SPs Executed/second
SMS 2003 性能测量: MP HINV 管理器(每秒报告总数) | 每秒报告总数
SMS 2003 性能测量: MP HINV 重试管理器(每秒报告总数) | 每秒报告总数
SMS 2003 性能测量: MP SINV 管理器(每秒报告总数) | 每秒报告总数
SMS 2003 性能测量: MP SINV 集合文件管理器(每秒报告总数) | 每秒报告总数
SMS 2003 性能测量: MP 中继管理器(每秒报告总数) | 每秒报告总数
SMS 2003 性能测量: MP 状态管理器(每秒事件总数) | 每秒事件总数

另请参阅

概念

Microsoft System Management Server 2003 管理包的其他资源
SMS 2003 管理包的站点和组件
SMS 2003 计算机组
SMS 2003 规则组
SMS 2003 的提供程序
SMS 2003 脚本
Microsoft SMS 2003 视图
SMS 2003 图表
SMS 2003 报告